[SOLVED] Sketchup 2017 slow after upgrading from 2016 (Nvidia 740M)

2017
nvidia
sketchup
opengl
bug

#1

Hi guys, I have an Ultrabook with i7-4500U, 8GB ram, SSD 500GB and a Nvidia 740M 2GB.

With this setup I can run Sketchup 2016 very, very smooth, but, after upgrading and redone all the configurations about hardware acceleration in nvidia’s panel [1], the 2017 version continues very slow.

I think, the 2017 doesn’t recognize my GPU to use hardware acceleration because I don’t have that option anymore [1], but the GPU specs show [2] the minimum to use that feature (and I almos forgot, all my drivers are up to date). Can someone help me to figure what’s happening?

[1] http://imgur.com/a/I4hfi
[2] http://www.geforce.com/hardware/notebook-gpus/geforce-gt-740m/specifications
Log file from Sketchup 2017 Checkup: SketchUpLog.zip (75.7 KB)

Thanks in advanced

PS: Sorry some mistakes, english isn’t my first language.


SU Pro 2017 Painfully Slow
#2

On the contrary, SketchUp 2017 will not work at all if the GPU doesn’t support hardware acceleration. That is why the option to turn it off has been removed.

I have an Asus ultrabook that has a Nvidia 620M and I haven’t noticed any significant lag in SketchUp version 2017 versus older versions. My models are small. Have you tried if lowering the Antialiasing setting (turn it to 0x to turn it off altogether) will affect performance. I noticed that SU 2017 uses that setting by default whereas older ones defaulted to 0x.

Your Nvidia driver seems to be recent but not the latest. You can always try upgrading it.

Anssi


#3

Thanks Anssi, but the driver isn’t the issue, I just updated and the problem persist, BUT, after that, I found the problem:

Use Fast Feedback: Fast feedback improves SketchUp’s performance, especially if you’re working on a large model. When you start SketchUp, it checks whether your graphics card supports fast feedback. If so, this option is selected by default. If not, this option is disabled by default. If your system doesn’t support fast feedback, you can still enable the feature manually by selecting the checkbox, but doing so may create more problems, rather than speed up your system.

After reading that, I unchecked the box and the Sketchup back to their normal state of performance.

Maybe Trimble can put a HINT in this checkbox to warning people about this side effect :slight_smile:

Thanks again


#4

That’s odd. I have never had Fast Feedback problems with Nvidia graphics. But I haven’t upgraded to Windows 10.

Anssi


#5

It didn’t work for me to only uncheck Fast Feedback. I had to uncheck all three options: hardware accelerator, max texture, and fast feedback. Thanks for your post which lead me in the right direction and solved my problem. This was such a headache to figure out.


#6

The option to turn off Hardware Acceleration is not available for SketchUp 2017.


#7

I am using SketchUp 2016 version