SketchUp 2017 extremely slow in rebuilding the screen

Why is SketchUp make 2017 so extremely slow in rebuilding the screen. AutoCAD Inventor en SolidWorks work fine! I do have a rather good laptop with a fast NVIDIA video card, that works fine with other 3D graphics.
But this version of ScketchUp zooms very slow and is rotating the view even worse!

Are there some settings that solve the problem?

I am a teacher and using the make version with my students, so they are getting acquainted with a 3D program, I earlier used version 8, that was very good, but this is a disaster!

There is no difference between Make and Pro editions regarding graphics performance.
(So I’ve removed “Make” from the title.)

SketchUp 2017 is the first to use OpenGL 3.0.

Recent Windows 10 updates have caused havoc.
(See other threads on “slow selection”.)
Selection Tool process is slow, unbearably slow
and generally:
https://forums.sketchup.com/tags/c/technical-problems/technical-sketchup-problems/slow


First, make sure SketchUp 2017 is using your Nvidia GPU, via Nvidia Control Panel.
You can verify within Sketchup via: Window > Preferences > OpenGL > Details

Many others still running Win7 or 8.x have not seen these slow issues.
Secondly, You can try and see if SketchUp 2016 runs better on your machine:
Older version downloads … https://help.sketchup.com/en/article/60107


On a related note, they do have no cost Pro licenses for qualified teachers.
https://www.sketchup.com/buy/resellers?type=education

Use fast styles, only turn shadows and textures on when saving a presentation,
use layers to control visibility (turning off things you are not working on,) etc.

See:

I tried the suggestions, but with 2017 there is no solution. I’m trying make 2015 now, maybe that works ? Thanks for the answer. De NVIDIA was recongnised, so that was not the problem

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.