SketchUp Make 2017 seems slow - openGL issue?

Hi All,

Rotating objects/ scrolling and moving objects is really slow on my machine - it is an issue when trying to move an object especially as there is a lag between when I move it (via the mouse) and what is displayed so I keep overshooting. I should have enough graphics firepower (see below) and it runs fine on my other PC with an older and cheaper card. Is this an open GL setting? Any suggestions?

Operating System: Windows 10 Pro 64-bit (10.0, Build 17763) (17763.rs5_release.180914-1434)
Language: English (Regional Setting: English)
System Manufacturer: To Be Filled By O.E.M.
System Model: To Be Filled By O.E.M.
BIOS: P1.60 (type: UEFI)
Processor: AMD Ryzen 7 1700 Eight-Core Processor (16 CPUs), ~3.0GHz
Memory: 16384MB RAM
Available OS Memory: 16316MB RAM
Page File: 12570MB used, 7250MB available
Windows Dir: C:\WINDOWS
DirectX Version: DirectX 12
DX Setup Parameters: Not found
User DPI Setting: 168 DPI (175 percent)
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
Miracast: Available, with HDCP
Microsoft Graphics Hybrid: Not Supported
DxDiag Version: 10.00.17763.0001 64bit Unicode

Card name: AMD Radeon Pro WX 3100
Manufacturer: Advanced Micro Devices, Inc.
Chip type: AMD FirePro SDI (0x6985)

If everything is configured right (drivers up to date, SketchUp set to use your graphics card) the bottleneck might be your CPU as its single-thread rating is rather low. SketchUp, like all 3D modellers, uses only 1 processor thread for modelling.

Verify SketchUp is using the AMD high performance GPU …

Window > Preferences > OpenGL > Graphics Card Details

… and check your settings … Fast Feedback

… and are you running a high anti-aliasing setting?

Restart SketchUp after making any graphics setting change.


Are you using a fast style in the working scene when you see this slow orbit or move ?

Hi All,

Thanks for the suggestions. I am using fast feedback, and currently I have 2X anti-aliasing on, but I tried 0X and it didn’t seem to make much difference.

It looks like Anssi is right - I thought I was fine for CPU, but when I opened resource monitor and I realized that when I rotate/ move CPU15 goes to max. Note that I never get above 20% for my GPU.

I guess I never considered that actions like rotate would require CPU over GPU horsepower.

Guess I’ll have to suck it up…

Thanks for the help!

Ah - just read the “Computer Game Graphics vs 3D Modeling Programs” post. Guess this makes sense now.