Sketchup make 2017 is slow

Hello, I have just recently acquired a new computer for the purpose of 3D animation.

But I have some problems with Sketchup make 2017, it is terribly slow.

I can’t even run some models, Sketchup simply freeze.

I’m on Windows 10 and here is my configuration:

  • Intel Core i7 9700k.
  • Samsung Internal SSD 970 EVO plus MVMe m.2500 gi.
    -GeForce RTX 2060 VENTUS XS 6G OC-Msi.
    -HyperX fury DDR4 2 x 32 GB 2666 Mhz CAS 16.
    -Asus TUF Z390-plus Gaming.

Do you think this configuration is powerful enough?

And here are the models concerned:
can you open them?



This model is really slow with shaddow actived:

Thank you for your help.

edit: i updated the robot links.

image

1 Like

If you look at model info -> statistics, what does it show for edge and face counts? If these are in the millions they will stress any computer.

https://3dwarehouse.sketchup.com/model/6baa5442-88f7-4b1b-bea3-809c50b4e1e1/Thales-Watchkeeper-WK-450 4422.12KB (4528246 Bytes)

But for the other model i cant launch them.

Make sure all (graphic) drivers are up-to-date.
Install drivers with the right-click:’Run as Admin’-method and SketchUp, as well.
After (re)installing, make sure that SketchUp is using the 2060
(Rightclick on an empty space of the desktop, choose Nvidia settings and make sure Trimble SketchUp Application is added in the 3D settings.
Check within SketchUp [menu]Window->Preferences->Open GL->Graphic Card Details

1 Like

Results from these models on my mid-2012 MacBookPro Retina:

The second model (gumball world) contains over 5 million edges, almost all of them in the tree! This kind of overmodeling of ultimately unimportant “entourage” is often an issue with models from the 3DWarehouse. It will crush just about any computer’s performance.

I added a new tag, assigned that tag to the tree’s group, and turned off the tag’s visibility. I also set monochrome mode (I didn’t check the size of textures but rendering them always slows things down at least a bit). WIth shadows on, the model is then just a bit sluggish. With shadows off it is fine.

The first model (robots) has a bit over 1 million edges, split about equally between the two versions of the robot. With this one simply going monochrome and turning off shadows makes it usable.

The third model is much simpler. The shadows lag just a bit but otherwise it is ok.

If you can’t get similar performance after making the tweaks I listed, there is an issue with the configuration of your computer. I will defer to windows experts to figure out what that might be.

Edit: I got first and second swapped above - fixed.

This one opens just fine for me, pretty smooth in fact when rotating the view. I downloaded the 2020 version as well.
Similar PC specs…
Dell Precision 3630
Windows 10 Pro 1903 (18362.357)
Intel i7-8700
32 gb ram
512 gb m.2 NVMe
RTX 2080 (driver v.430.58)
38" Dell 4K U3818DW

I followed your instructions and indeed, sketchup was not using the 2060.
the performances are better than earlier.

you are right, the 3D model “The Amazing World of Gumball Elmore school” is too detailed, this is explained by the fact that I really like adding details to make them realistic

But what intrigued me was that the 3D model freezes Sketchup while another of my 3D models looked more complete (a nuclear power plant with a modeled interior) works very well.


But I am reassured that the problem comes from my creations and not from my configuration.

my problem has just been solved, I will surely come back to you if I have another problem.

Thanks a lot for your help :wink:

Two suggestions to make life easier in the future:

  1. Substitute low poly proxy components for edge-heavy ones while building a model. That way you will get decent performance while building and editing the model. When the model is complete, set up the scenes you want for view or rendering. Only then swap in the high-detail components for the final output. This workflow will avoid stalling your progress waiting for the computer to handle a massive model.
  2. Always download things you didn’t create yourself into a stand-alone model first and examine them to see whether they are appropriate for your needs. For example, I really doubt that a tree with 5 million edges is necessary for realism! Often you can find a much simpler but adequate alternative, and sometimes you can simplify a component by eliminating details that won’t really be visible anyway.
1 Like