Sketchup 17 make slow

i have been using sketchup make 16 with no problems at all but after installing make 17 i am finding that whatever i do it is so slow initially saying not responding but does eventually work after about 30 seconds this applies to whatever i try and do.
I installed 17 with administrator rights and have done the sketchup check system which says everything meets the requirements.
i am using an HP 820 g1 laptop ,I have open gl 4.3 ,and I7 4600u processor. 12gb ram, and windows 10 pro,
I am using the same file which ran ok on this same pc using sketchup 16 make with no problems and was quick. but it is virtually unusable with 17 as it is so slow.
Can anyone offer any advise or shall i stay using 16?

Thanks

In SketchUp 2016, did you have Hardware Acceleration disabled under Preferences>OpenGL?

Go to the Intel site and get the latest drivers for your graphics card.

Your profile indicates you have an Intel 440. Is it possible it’s a 4400?

Hi Dave

Thanks for the reply

Yes it should read 4400 and not 440

I have all the up to date drivers via iobit driver updater

I am up to date with no more updates available to windows

I can not find hardware acceleration in the graphics options but settings are as below

3d profile app optimal enabled

Multi sample anti aliasing using app settings

Conservative morph anti aliasing enhance app setting

Performance balanced

Profile triger

Sketchup app is on the list

Automatic adjustment is enabled

Video image scaling disabled

Gamut mapping is disabled

I am not sure what some of these settings do but they are set as above

Thanks

Peter

Mail](https://go.microsoft.com/fwlink/?LinkId=550986) for Windows 10

OK. This graphics card as with other low-performing integrated graphics cards don’t have great support for OpenGL which is required for SketchUp.

It would be worth checking directly with Intel on the graphics drivers.

The option to turn off Hardware Acceleration was last available in SketchUp 2016. It was removed for SketchUp 2017. If you still have 2016 installed, you could look in Window>Preferences>OpenGL to see how you had that set. Turning off Hardware Acceleration gave rendering duties to the CPU and was used to compensate for inadequate GPUs. With the release of SU2017, SketchUp requires a suitable graphics card to work properly.

By the way, could you please update your profile with the correct GPU?

Hi dave

i checked with intel and it did find updates for my bluetooth and wi fi but nothing else.

I looked on my sketchup 16 make which i still have installed and am still using ok and the hardware acceleration is enabled and fast feedback is also enabled?

I will edit my profile to read correctly.

Do you have any other suggestions or do i have to stay using 16?

Thanks for your help

Peter

If leaving Fast Feedback turned off works for SU2017, you can use it. Just be aware that integrated Intel graphics are not recommended. Also watch for performance changes after automatic Windows updates. They are notorious for pushing broken graphics driver updates.

you may try if disabling the Fast Feedback option in SU v2017 helps, if not stick w/ version 2016 until you upgrade your system.