SketchUp 2017 Really Slow


#1

I just installed the SketchUp 17 because i was having trouble with SK16, but aperently the problem persist.
The problem is that when i open SK, everything lags, i cant select propper or pull or anything.
I try many things and realize that runing SK17 with the internal card resolve everything.
What can i do to run it again on my external video card?


#2

install the latest graphics card driver provided by the maker of your notebook first (and not directly by nVidia) even if older.


#3

Goto Window/PrefernecesOpen GL and Un checked the - Use Fast Feedback:box. I’m running on a new GTX 1070 and I was horrendously slow until I unchecked this box. Now runs fine on big models…