SketchUp 2017 becames generally slow

Hello guys,
I am experiencing problems in my SketchUp 2017 Make for some time… Here are my problems:

  1. It’s been months when I find SketchUp too slow to switch tools, especially between camera tools (orbit, pan, etc) to construction (line, rectangle, etc) and vice versa. It takes too long to switch tools, which I find unusual because it is almost instantaneous to switch when I first installed the software, after months, it switches for about 5-8 seconds, with occasional longer than 12 seconds of tool switch. I experience this everytime I use SketchUp now in mostly of my models even in my smaller than 1MB models.

  2. With the previous problem, while it takes too long to switch between tools, it became non-responding software for some seconds. During the tool switch, it becomes non-responding for a couple if seconds, back again normally, then became non-responding again when I do tool switch.

I don’t use other heavy softwares together with SketchUp. But still I experience this problems and always interfere to what I do in SketchUp, even in small models. I’m hoping to solve this because I need to practice my skills, especially on speed on using SketchUp, which is vital in our course for college.

These are my laptop’s technical specifications:
Lenovo Ideapad 330 14"
CPU: Intel Core I3 7th Gen
RAM: 4GB
Graphics Card: Integrated Intel HD Graphics 620 2GB, Dedicated AMD Radeon 530 2GB, Total 4GB
Storage: 1TB HDD
OS: Windows 10 Pro 64-bit
SketchUp Version: 2017 Make

Your responses are very well appreciated. Thank you very much.
-MJ

This is the most common cause of slow downs like you report. Most likely an automatic Windows update included a broken Intel graphics driver. Although the Radeon is a low-performance GPU, it may be better than the Intel graphics. Update the graphics drivers for both directly from the manufacturers. Don’t trust Windows to tell you if the drivers are up to date. Then try running SketchUp with one or the other and see if you get better performance.

Ahh, so direct updates from the manufacturers will be able to solve this problem?
Noted, I’ll do this.
By the way, how can I run SketchUp using the AMD graphics card? I’m trying to explore the AMD Radeon software to try using it on SketchUp, as well as to change the graphics card setting on the SketchUp itself, but it just didn’t work. So I use my Intel graphics card in running SketchUp. Thanks for the response.

Maybe. No guarantee.

It may be that your AMD graphics card won’t run SketchUp. There should be a control panel for it where you can select which applications use it.

Integrated graphics are not recommended for use with SketchUp but some people manage. IF you find a driver version that works well, make sure you keep a copy of it so that you can reinstall it when Microsoft pushes another bad driver.

I understand your budget may not allow it but the best option is to get a computer that has a suitable graphics card. Nvidia GTX series graphics cards seem to produce the best results and users rarely ever report issues related to them. A computer with something in the GTX1060 or newer would be a good choice.

1 Like

This will be noted. Thank you. I’ll update if there will be some improvements in this issue.

Lastly, will downgrading my SketchUp into 2016 will somewhat improve the overall speed? I used 2016 these last years and I didn’t have any problems with it, even if I’m using a potato laptop worse than my new laptop.

SketchUp 2016 has an option in the OpenGL settings to turn off Hardware Acceleration which makes the CPU do the rendering work. This was included to avoid using graphics cards that aren’t up to the job. That option was removed with the release of SU2017. So you might see better performance in SU2016 just because you don’t need to rely on the feeble GPU.

I would save the potatoes for eating. :wink:

1 Like

Well, I could try to do the manual driver updates first and try if things will work fine. But if not I’ll reconsider downgrading my SketchUp to 2016, and disable Hardware Acceleration. I think the Intel Core I3 will do much better than trying to pass the work either on Intel GPU or on AMD GPU, on my opinion. Hahaha

By the way, thanks DaveR for the responses. These are well appreciated.

Good luck. I hope it works for you. Have a great day.

1 Like

I have Nvidia 9600 and the built-in Intel chipset. I have multiple displays and Sketchup obviously selects the Intel driver which causes the slowness.

What I did was go to Windows 10 settings, select System, Display and Advanced graphics settings. Then Select “Classic app” from the dropdown menu. Now click the Browse button and locate the sketchup.exe file. Press “Add” which should add the exe to the list of applications. Select sketchup from the list and press the “Options” button. Now you can select the “High perfomance” option and save.

The above should result in Sketchup using the fastest GPU available and it truly worked in my case. The slowness of the Selection tool is now gone!

1 Like