Sluggish/Choppy


#1

I have a new system. HP Envy, 16g RAM, with NVidia 940MX graphic card with an additional 4g dedicated to video. I have used Sketchup 2017 on this system for over a month now. I recently bought a license. On this past Thursday I used the program to do a 3d mock up and it worked flawlessly with no issues. Today I open the program back up and start a new file with a floor and 2 walls (so nothing complicated) and when I use the rotate tool (or any tool) the model it is choppy, and sluggish in response. I have already tried un-installing and re-installing the program (no change). I looked at the OpenGL settings and they are still set to factory as I had them before. I have ran other graphic intense program (i.e. Photoshop 2017, etc…) and they have no lag. I also ran some antivirus software to see if I had picked something up from somewhere that would be running in the back ground. (if I had it would be affecting all programs though I think). Nothing caught. Any one have any ideas? I am at a loss. I did submit a ticket in to tech support but will not get an answer until Monday, at the earliest, if I am lucky. I would appreciate any help given. Thanks.


#2

O, forgot to say that I am running Windows 10 - Home.


#3

You may need to elaborate on this.
How is it set and is it using the Nvidia card? not an integrated one.


#4

You should make sure that in the Nvidia control panel 3D application settings SketchUp is set specifically to use the “High-performance Nvidia graphics”. The default “Automatic selection” doesn’t work.

SketchUp should perhaps talk to Nvidia about this. Otherwise AMD cards are not as good with SketchUp as Nvidia but with them SketchUp defaults to ignoring the integrated Intel graphics.

Anssi


#5

Box, here is a screen shot of the Open GL settings that I have not messed with. I hope this is what you were asking for clarity on. Thank you for your help.


#6

Anssi,

I have tweaked the Nvidia control panel and added Sketchup to always use the high performance card. I made the changes as you suggested and restarted the system. Still no change, but thank you for the suggestion. Didn’t know I had that kind of control over the graphics card on this system. Any other ideas?


#7

I can confirm I’m having a similar problem. I was working in a large model on Friday without any issue, and now even the simplest model is very sluggish. I have a feeling it’s associated with the update NVIDIA installed ( 21.21.13.7654) on my 960M… Going to see if I can roll back to a previous version.


#8

Confirmed. I rolled back the driver to the previous version, and everything is working fine.

In Windows 10, go to Device Manger, Display Adaptors, double-click on the NVIDIA Driver, go to the Driver tab, and click Roll-Back Driver.

This isn’t a permanent fix, but it at least got me up and running again.


#9

you’re a savior!


#10

NVIDIA recommended I do a fresh install using this program. Seems to have worked- http://international.download.nvidia.com/Windows/378.57/378.57-desktop-notebook-win10-64bit-international.hf.exe