Upgrade gpu = lag and crash

crash
nvidia
sketchup
vray
vray3.4

#1

Hello,
I changed my graphics card, I had a AMD 290X R9 (2013) and I just installed a NVIDIA 1080 (2016) and I have a lot of slowdown in Sketchup (even crash), the V-Ray plugin crash now

It’s really weird, it was fluid with big project and I could do very nice rendering with V-Ray but now I can not do anything anymore …

Any options or settings to change for resolve this problem ?

Skechtup Pro 2017 + Vray 3.4
Windows 10 Home x64
EVGA GTX 1080 FTW Hydro Copper


#2

Did you Tie SU to the 1080 in the Nvidia settings? Access them by right clicking on the desktop, should be in the context menu.


#3

I only have GTX 1080, my integrated gpu is disabled, so I don’t have this option in NVIDIA® Control Panel


#4

Out of interest, If you go to,
Window>Preferences>OpenGL

Does the 1080 show up in that window as being used by SketchUp?


#5

In “Graphics Card Details” I found “Vendor: Nvidia Corporation” “Renderer: GeForce GTX 1080”
I think Sketchup use my card


#6

That looks good then. When you installed the card did you get the latest drivers from the nvidia site or use a disc? If you did use a disc the drivers are probably past their best and need updating.


#7

No CD Drive so I’ve downloaded the latest driver on Nvidia website


#8

Update the V-Ray, too


#9

Yes but even without Vray, Sketchup is very slow and laggy ¯ _(ツ)_/¯


#10

How did you install SketchUp and V-Ray?


#11

.exe, right click > Open


#12

See this:


#13

Btw, you don’t need to uninstall SketchUp. Find the installer, right click and choose “run as administrator”. When prompted choose the “repair” option.

Doing it this way should leave all your toolbars and extensions as they were, so no need for any additional setting up again.


#14

I uninstalled Sketchup 2017 then installed the 2018 version and install vray in 3.60.02 but I still have lags and crashes …


#15

You did not have to remove 2017, each version is stand alone. This is where the link is made, Go back to the Nvidia settings>manage 3D settings>program settings.


#16

2017 is useless if I have 2018 ^^

“Select a program to customize: Trimble Sketchup”
Ok, after ?


#17

Each is separate they can co-exist with each other. Many of us have several versions installed.
I am currently working on a fresh install and my 1050Ti is out for RMA. I cannot give the exact steps. Scroll down the list, should be something to link the GPU, I forget the exact wordage.


#18

I have only one Trimble Sketchup (when I install a newer version I uninstall always old versions) and I have only GTX 1080 (Integrated GPU is disabled, HDMI is from my 1080) so it’s obligated to link with 1080

In NVIDIA® Control Panel, Manage 3D settings, Program settings, I can only change settings like “Anisotropic filtering, CUDA, Ambient Occlusion”

So I have this : http://i54.tinypic.com/if7alx.jpg
And not this : https://www.howtogeek.com/wp-content/uploads/2013/11/nvidia-manage-3d-application-settings.png
(So I don’t have “Select the preferred graphics processor for this program” option)


#19

You should have an option to set the 1080 under global settings then customize it under the program settings.
EDIT:
The line is " Preferred OpenGL GPU". Use the drop down to select your 1080.


#20

FYI: The license for each version must be removed before uninstalling. (Each version has it’s own license.)
You will not be able to assign the old license to another machine unless it is removed before uninstall.

SketchUp User Guide

You likely need to run the patch script for 2018 …

As far as VRay goes. Do not load it until you need to render.