SU get stuck while using High graphic design

I got a situation at using skech up …
Some Spec of My PC graphic card is Nvidia GeForce Gtx1050 and OpenGL Version of 4.6
It’s Ok to design in autoCad and do a good work at redering though it take a little long time in autoCad
But when I started to use Sketchup it was running so well and quick
before I started to import some units from warehouse…
Especially some trees and hedges with detail drawing… and at V-ray reder too, it doesn’t work so good…
besides them… There’s no hardware acceleration to check and uncheck in preference setting.
What is my problem plz explain something…

Try purging your model of unused stuff. Look at the components you’ve inserted into your model from the Warehouse. Dollars to Donuts some if not all are excessively over modeled and could do with some simplification.

In SketchUp, go to Window>Preferences>OpenGL and click on Graphics card details. Make sure it says that the Nvidia card is indeed being used by SketchUp. If it’s not, change in the Nvidia control panel.

Go to the Nvidia site and install their latest drivers for the card. Don’t trust Windows to tell you that the drivers are up to date.

No. Of course not. That went away when SU2017 was released.

Thank You For Your Reply Sir…
Yes My Sketch Up is using that Nvidia Driver indeed…
But I’m thinking that it would be better if I used another version of Skechup??

Which one?

I expect you really need to just improve your model’s efficiency.

Since version 2017 Hardware Acceleration always has to be ON

I think your expectation is sure because I’m actually a beginner…
May I get something to learn to improve it…

Start here: https://learn.sketchup.com/

Thank your so much mr.Dave…

Thank you for your reply which gives me fulfilment