Hardware accelaration is unsupported or has been disabled

Hi Everyone,

I’m currently unable to open SketchUp. Every time I try to, I get the Error message many seem to get, “- Hardware acceleration is unsupported or has been disabled on your graphics card. SketchUp requires that you use a hardware accelerated graphics card.”

I went through a few different forum posts, and none seem to suit my needs. I have an NVIDIA GeForce GTX 1650 Graphics Card. I have made sure to set the Graphics preference for SketchUp to High Performance to always use the NVIDIA, and I continue to get the error. The funny thing is that when I set SketchUp’s preference to Power Saving using the Intel UHD Graphics 630 card, SketchUp will begrudgingly open but with a warning of, " SketchUp has detected your computer system has multiple graphics cards and is defaulting to an integrated Intel graphics card. SketchUp will perform better if you change your system to default to the AMD/NVIDIA card." SketchUp opens, but I’m pretty sure I’m supposed to be using the NVIDIA card.

I have updated my NVIDIA card, and it says I am operating with the latest driver. I even set the settings in the NVIDIA Control Panel per this page’s recommendations: Resolving NVIDIA error message | SketchUp Help. Still nothing.

If anyone has had this issue or knows what to do, that’d be great! I’m anxious to get back to work in SketchUp, and I’m fairly frustrated right now.

Thanks so much in advance!

One of the Windows 10 updates added a new feature, where you can do scheduling for the GPU. I don’t fully understand the feature, but it does imply that the GPU may be shut down if it appears not to be in use.

Check this article, and see if changing the setting makes a difference for you:

Thank you for the quick reply! I have tried it both with that setting switched on and off - nothing changed.