Issue with starting sketchup and potentially Intel graphics card

Since doing a windows update a few weeks ago I have had problems with starting sketchup. Having searched long and hard on various forums I found someone report that the on board Intel graphics card (in my case UHD Graphics 620) created an issue with starting sketchup, despite my machine using and being directed to the NVIDIA graphics card (Geforce MX150) via the NVIDIA Control panel. I instead chose to use the Microsoft display adapter instead of the laptop using the Intel one and initially this worked (i was getting a Bug Splat message every time since the update). However, i also use Autocad and in removing the Intel driver this created an issue in Autocad (lines doing strange things in model and layout view) which is only fixed by turning off Hardware acceleration. If I then want to use Sketchup this now creates a startup issue:

‘Hardware acceleration is unsupported or has been disabled on your graphics card. SketchUp requires that you use a hardware accelerated graphics card.’

In doing a sketchup checkup I get the following errors:

Results:

Error: Something went wrong while retrieving the system information from your computer. This may cause tests regarding System RAM, Windows version and/or graphics card memory to fail.
Error: Hardware acceleration is unsupported or has been disabled on your graphics card. SketchUp requires that you use a hardware accelerated graphics card.
Success: System RAM requirement has been met!
Success: Operating system version requirement has been met!

The hardware acceleration is still on according to my graphic settings. It seems that Autocad is unhappy when i remove the Intel driver and Sketchup not happy when it is being used, but I never had this problem before and been using the laptop for approximately 2 years since new. I have updated both the Intel (via Lenovo website) and NVIDIA drivers (via NVIDIA website/ Geforce Experience) to the latest ones and still had the problem.

As mentioned I’ve researched quite a lot but i’m getting confused now as to what I need to do, so any help will be greatly appreciated.

Thanks, Jonathan

I should note that in playing with this further I am noticing that Sketchup will open without a problem if I disconnect my laptop to the large monitor I use to help to extend my display. Does this mean the driver for the additional monitor may have an issue? It comes up in the device manager under display adapters as a Thinkpad USB 3.0 Ultra dock.

Thanks

I have been trying hard to figure this out, and we have an ongoing bug report about it, hoping to find ways to make the problem happen.

The last Windows update introduced a new feature, where the GPU can be shut down if it isn’t apparently in use at the moment. I did have one customer case where turning that feature off solved the problem. You could try that too.

I am using a later version of Windows 10 than most people are, and I see that the feature has been removed. Here’s an article about it.

Hi Colin and thanks for the reply.

I just tried turning this Hardware acceleration scheduling off as mentioned and restarted but it made no difference, still got he bug splat when my laptop is connected to my separate Dell monitor. I just sent an error report off. I’m wondering if it isn’t just this monitor that is now causing the trouble? I just update the monitor drivers to see if that makes a difference but Sketchup still won’t open when connected to this monitor.

Anything else I could try? Thanks

It is probably the dock that has problems with OpenGL compatibility.
Have you tried connecting with a hdmi?

Or DisplayPort, if available
Also, if the “USB 3.0 dock” info is correct you might also try updating the dock firmware and the Thunderbolt software. It might also make a difference what cable and connector is used to plug in the monitor to the dock (HDMI, DisplayPort or USB/Thunderbolt).
Older Lenovo docks (the types where you put your laptop into a cradle) didn’t support OpenGL or the Nvidia graphics cards through the dock.

Hi Mike,

I will try the hdmi cable direct from laptop to monitor, currently working remotely but will try tomorrow and feedback. I think as you and Anssi mention the dock could be the problem.

Thank you.

Hi Anssi,

Thanks, will try updating these as you mention when i’m back by my monitor tomorrow.

Its a USB/ SS connector into my laptop from the dock, and i use a (double ended) hdmi cable between dock and monitor.

Will feedback my finding tomorrow.

I’m having the exact same issue.
I have a completely new Lenovo laptop with Nvidia Geforse 1650 GTX and the Lenovo Thinkpad USB 3.0 Ultra Dock to be able to have external screens at my office.
When I unplug the ThinkPad USB dock, SketchUp and Layout works great, however, when it’s plugged in both SU and LO crashes immediately and shows a Bug Splat.
It’s frustrating as all other applications work without any issues.
I have Autodesk AutoCad 2021, Revit 2021, Photoshop, Illustrator, InDesign and other apps requiring good GPU resources. And they all work!
Only SU and LO keep crashing. It’s annoying and embarrassing!

Unlike SketchUp, these don’t require OpenGL.
My work setup uses HP hardware. I had difficulties with my external 4K screen until all firmware and software related to the USB dock was updated.
I still wonder if Lenovo has kept up with its old practice of not supporting OpenGL through its docks. I had the exactly same problem with a Lenovo “portable workstation” and dock years ago. Have you tried plugging the external monitor directly into a DisplayPort or HDMI port on your computer?

1 Like

Hi Frederik,

In a nice kind of way i’m glad that i’m not the only one experiencing this then!! I’m using Sketchup more than I used to now but don’t remember it happening before. Sounds like you use almost an identical programme suite to me too and it’s the same for me, I have no problems with these other programmes.

Will try these tips the guys mention above when I get a chance, let me know how you get on with these too and hopefully there will be a resolution.

1 Like

Thanks for the heads up, Anssi. Much appreciated.
I assume that it’s because Lenovo has kept with their old practice of not supporting OpenGL through its docks.
I haven’t tried plugging the external monitors directly into a HDMI or display port.
But I sure will give it a try first thing tomorrow, when I’m back at the office.

I just found out, that we’re not alone having this issue…
Take a look at this topic posted a while ago: Docking Hardware acceleration is unsupported

Hi Anssi and Mike,

So i’ve tried plugging my hdmi cable straight into the laptop (missing out the dock) and sketchup opens fine which is great news! Guessing my dock is an old one but presume i can still use the dock/ SS or USB cable for my ethernet connection as my laptop has no port for that.

I also checked the device manager to make sure i had the latest updates on the system for the dock firmware and thunderbolt software and apparently it has. Or would i have to get the latest updates from the manufacturers websites? I have attached screenshots below of the items i checked on my system, so please correct me if these are the wrong ones.

Thanks for all your help

Hi Frederik,

Yes i saw that post when i was looking before, i just didn’t think to check the hdmi cable separately as i use the dock for the ethernet cable too.

Hope doing this resolves your issue to.

Hi Jonathan,

Yes - I also tried this yesterday with success.
However, it requires that it’s the main screen which is connected to the laptop using the HDMI cable.
If I switch the main screen to be the one connected to the ThinkPad dock, SU crashes immediately.

Just minutes before I tried the “trick” with the HDMI cable, I ordered a new docking station.
I hope this will also work - if not I will return it.

1 Like

Good news Frederik! Hope the new docking station works but yes suppose you could always send it back if it either doesn’t work or is just redundant now that you can plug the hdmi cable straight into your laptop.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.