Docking Hardware acceleration is unsupported or has been disabled on your graphics card

lenovo
#1

Hello

We have a problem at Lidl Denmark with Sketchup Pro and our Lenovo docking stations.

When a laptop is connected to a docking station or port replicator it is not possible to start Sketchup Pro.

The error message is the following.
!!!-------
The following errors were found when launching SketchUp:

  • Hardware acceleration is unsupported or has been disabled on your graphics card. SketchUp requires that you use a hardware accelerated graphics card.

Unfortunately, these errors will prevent SketchUp from running. Updating your graphics card drivers might fix the problem.

See this Help Center article for more information.
-------!!!

When connecting the monitor to the laptop direct the problem goes away.

Could anyone help to find a workaround?

0 Likes

#2

The list of potential issues is quite long.

Firstly, the ideal solution is to upgrade to desktops with dedicated GPU’s.

  • Your laptop does not have a dedicated GPU so that adds to the challenges.

  • The Win 10 Intel GPU driver apparently is not completely compatible with SketchUp.

  • Also, your docking station may have incompatible hardware.

Second option may be to upgrade your docking stations or at least look for any updates with firmware or drivers. Make sure your laptop bios is up to date.

0 Likes

#3

You could also look into external GPU’s, if your laptops are new enough and have a compatible port.

0 Likes

#4

I have seen this too with older Lenovo docking stations and older Lenovo W-series notebooks - they don’t support OpenGL through the dock. Trying a more modern port replicator might help. Today I have a HP laptop and a HP port replicator that doesn’t have this problem (it also supports my 4K monitor - older models have resolution limitations too). It is a bit hit and miss with these - I haven’t seen OpenGL mentioned in the documentation.

0 Likes

#5

Hello

Thank you for your replys

As Sketchup can run on the laptop when it is not connected to the port replicator it has nothing to do with the onboard graphics card not being able to handle Sketchup. It runs fine without the port replicator.

I can also run Sketchup when connected to the port replicator but with the monitor connected directly to the laptop.

Have tried this with the Lenovo usb 3.0 universal dock and a HP usb-c universal dock with the same result.

Just tried to remove the usb docking cable. Startet Sketchup and then put the docking cable back in and Sketchup is running fine now over the port replicator.

There should be some fix to this issue with the startup check in Sketchup so you could disable the OpenGL check as this is clearly not necessary for Sketchup to run.

0 Likes

#6

It is necessary. From version 2017 on SketchUp requires a graphics card with full OpenGL hardware support. In earlier versions you could switch to software OpenGL rendering by turning hardware accleration off.

This indicates to me that docking your laptop to your current docking stations or port replicators tries to switch your Nvidia graphics off, for some weird reasons. Another thing that I saw with older Lenovo docks was that connecting your laptop could switch your display to using 16-bit colour instead of the full colour required by SketchUp.

0 Likes