Why don't YOU just fix the bug with DisplayLink Docking stations?

I have used mostly the free version for years… got pro finally through work and it is fine, especially with the ability to finally get CAD drawings directly into it. I was using a Docking station with DisplayLink drivers but it died so I picked up a Dell D3100 USB 3.0 dock to replace it. Then I got the stupid “- Hardware acceleration is unsupported or has been disabled on your graphics card. SketchUp requires that you use a hardware accelerated graphics card.–Unfortunately, these errors will prevent SketchUp from running”. error when trying to fire up Sketchup.
What I don’t understand is that it crashes due to Graphics card sensing issues, but if I open up the program with the dock disconnected I can then connect and there are NO noticeable issues running it. If there are no issues after it is open, WHY not fix the way it handles a DisplayLink system so it just works??? My main reason for using a dock it so easily KVM to my personal PC as well with my keyboard, mouse, and dual monitors. image

I have 2 different display link adapters and I can swap different laptops in and out on them without a problem.
Firstly Have you installed SU by using the Right Click and Run as Admin on the installer.exe? This is not the same as installing while being signed in as an admin, nor is it running SU as an admin.
If not do it now and select repair when given the choice.

What graphic card/cards are you using and are the drivers updated directly from the manufacturers website, not simply via windows?

What Graphic card shows up in Windows/Preferences/OpenGl when SU is running?

It is not a SketchUp problem. If you used other OpenGL software it would affect them too.

You should ask DisplayLink to update their drivers, or look for updated drivers and firmware for your docking station. Old DisplayLink docks do not support OpenGL through their connection.

I have had success with newer HP docking stations with a Thunderbolt (USB 3.0) connection.

1 Like

Both my computers have thunderbolt but there wasn’t an inexpensive version of a thunderbolt switch. ALL drivers are updated. Like I said I was able to use my OLDER Kensington dock without an issue with my Lenovo, but my older HP had the same problem.

If you go into Graphics Settings, browse to where SketchUp.exe is, and add it to the list of applications, then in Options set SketchUp to use the higher performance GPU, does it cure the problem?

Some screenshots to see the steps I mean.

1 Like

I have to add that my “success” involved some serious tweaking (problem wasn’t with SketchUp * display but connecting a 4K monitor):

  • updated my computer BIOS
  • updated the BIOS in the Thunderbolt dock
  • updated display drivers
  • updated the Thunderbolt driver & software
  • updated network driver
  • switched the 4K monitor to use a Thunderbolt cable instead of HDMI

The first DisplayLink I tried was years ago, a Lenovo brand dock with a Lenovo laptop, and that wouldn’t run OpenGL.

By the way, I do know of at least three issues with DisplayLink ports. A colleague loaned me his to do tests, and it’s sat on my desk at the office. I may drop by some time and bring it home, so I can do more testing.

The hardware acceleration is one of the problems, though I’m not sure if I’ve seen that happen myself. Another issue is where SketchUp opens, and then crashes when you start a new document. That may have been a Windows issue, because for a while SketchUp was being told it is getting the discreet GPU, but when the window actually opens it’s the integrated GPU, and SketchUp starts talking to it like it’s still the discreet GPU.

The third issue is one I can easily make happen all of the time. If SketchUp opens on the first monitor, but the document opens on the second monitor, the document remains in a not-responding state. It’s easy to work around, just make sure to open the document on the main monitor.

This did not help… thanks though.