Help: "Hardware acceleration is unsupported or has been disabled on your graphics card"

Hello, I’m having the following issue on my PC: Sketchup won’t start, the following message appears when trying to run it:

"The following errors were found when launching SketchUp:

  • Hardware acceleration is unsupported or has been disabled on your graphics card. SketchUp requires that you use a hardware accelerated graphics card.

Unfortunately, these errors will prevent SketchUp from running.

See this Help Center article for more information."

I can’t recall when this started to happen. I’m using Windows 10 and my graphics card is AMD Radeon RX 480. Windows and my graphics card are up to date. I tried uninstalling and re-installing my AMD software and Sketchup, but without result. Any help is appreciated.

according to your profile your are using a “NVIDIA GeForce GTX 1650 Ti” …which would have worked.

Check directly at AMD if there is a more recent driver version available, if not swapping the graphics card to a GeForce GTX/RTX w/ an appropriate OpenGL support is inevitable.

Hi, yes the Nvidia Geforce GTX 1650 Ti is from my laptop (where Sketchup works), but right now the problem is on my PC, where it doesn’t work with my AMD Radeon RX 480…

I noticed the drivers on the AMD software were outdated, so I installed the latest from their website. Apparently Windows out ruled those drivers because Windows strangely enough doesn’t detect the latest AMD drivers through their update system, so I ended up with having two drivers, which forced me to reinstall the AMD software. I then installed the latest AMD driver again on their website and this time it worked having just the latest driver, but I still get the same error on Sketchup…

This isn’t unusual. Windows passes it’s own version of the drivers in Windows updates. If you ask Windows if the drivers are up to date it will tell you that they are because it’s looking for the version included in the last update. That’s the reason for the advice to check with the GPU manufacturer for their drivers.

It’s unfortunate that the AMD drivers aren’t as good at supporting OpenGL like Nvidia has historically been.

I just got the same error from my small laptop. Updated my Nvidia driver, checked the settings etc. until I realized that the power cord was not in the outlet and my battery was nearly empty :person_facepalming:

So power saving settings can also be the reason why your computer refuses to use discrete graphics.

1 Like

Thanks for the tips guys, I’ve checked my power settings, but that’s not it either. I noticed Illustrator has GPU Performance disabled aswell, because it’s not compatible for some reason… I would expect a high-end graphics card like the RX480 would support it, or is there something else outside the GPU that may get in the way?

There is a setting on Windows but it is kind of hidden:

You need to reboot, I believe

Hi guys, quick update here: I fixed it with the help of an IT expert by repairing my pc (with the use of two command prompts in Windows). Apparently Windows was corrupted since it found some corrupted files (perhaps due to updates). Now everything works again!

1 Like