SU lagging of pan/orbit

When panning or orbiting, every 4 seconds the model movements on the screen don’t follow the mouse input. This lag lasts for about a quarter of a second.

I have exhausted my knowledge of settings and tricks…and would appreciate help - cheeers


  1. Same happens with 3D Connextion spacemouse.
  2. Latest SU Pro Version 23.0.419 64-bit for desktop PC
  3. file is store on local drive (C:\Users\hnrkn\Sketchup LOCAL\2104 MOU\SU)
  4. modest file size 23MB, recently purged. <23k edges, 5k component instances, 2300 component definitions
  5. the view is using a ‘fast’ style: no profiles. Note: dashes or transparentlc on/off does not show improvement
  6. Validity check (“fix problems”) did not indicate any any errors
  7. Anti-aliased textures (in SU model info > rendering) on/off does not make a difference
  8. Multisample (in SU Preferences>Graphics) 0x, 2x, 4x etc does not make a difference
  9. graphic card NVIDIA quattro P1000. I have set up NVIDIA to use this dedicated graphics card



What mouse are you using?

You have 125 materials, maybe one of various are too big. Did you downloaded models from the 3D warehouse? Some models are unnecessarily detailed for being assets. We would help you better if you share the file, of course if you can do it.

10 year old corded HP mouse. And 3DConnexion cordless spacemouse.

For materials, I used ‘Architexture’ plugin and a few supplier-sourced images.

Indeed two large textures were found, so I used Curic Material Resizer to reduce all textures to 512 pixels.

Purged once more. 98 materials remaining now. 14.8MB file size now.

Unfortunately the lag persist :frowning:

Here is the lag shown after material resizing, spinning with SpaceMouse and screencaptured with gif (which made it a bit jagged, which is not part of my lagging problem)
Sorry to make you seasick!

Can you share the file so we can check if it’s a model or a pc problem?

dropbox link

I`d be super glad if one of you could take the time to check the file. Thankxs for your time!

Even with shadows I don’t get any lag.
This is windows 11 32gig ram Nvidia rtx 2080

The same for me, I’ve tested it on my windows and Mac machines and I don’t get any lag, it must be a gpu problem. @hnrkndr have you updated the drivers from Nvidia’s website or using GeForce experience software?

Thanks @Box and @francisquitof for your time!

YEZZZZZ! the Nvidia update solved it!
I can`t believe I did not think of this!
My last driver install was just 3 weeks old. Incredible how fast-paced the development of drivers is!

FYI, Before I updated the NVIDIA driver, I tried a few more things. It may help others later if I listed these attempts anyway: :

  1. I confirm that no far distant objects are in the model
  2. Disabling all extensions did NOT make a difference
  3. I have copied the geometry + pasted into a brand new empty model. It DID remove the lag!!! - (straaaange - thats with the old driver) … But scenes and sections were of course lost…

I owe you one!
And all you frequent contributors, you should get paid by Trimble!

1 Like

OHHH NOOOO!!!. I thought I put the issue to bed yesterday, but this morning the SAME lagging issue appeared!

Unfortunately, repeating yesterday`s steps did NOT help this time - yikes!

So, I tried another way:
windows settings > device manager > display adapters > NVIDIA Quadro P1000 > Properties > update driver > let windows search for driver
And interestingly this found another driver.
But DIDN’T help either :frowning:

All my other models above 8MB file size show lagging when panning/rotating. Some more noticeable than others. The greater the file size (biggest file is 48MB), the more noticable.

Time to lodge a trimble support case!

Unfortunately I think you will find it is the Quadro Card that is the bottleneck. They have often been shown to not be worth the extra money for this type of work.


Even my old Nvidia GTX970 has no lag when navigating around your model.

1 Like

thanks for double checkin`, Dave.
It shows that I have a local problem.

I appreciate your time spent on this case.


I am about to upgrade my graphics card (for deep-diving into the V-Ray world).
Let`s hope the problem disappears then

The GPU performance tracking (with Task Manager) revealed that the NVIDIA Quadro P1000 graphics card is utilised only 14% when rotating the model.
During approx 30 seconds of rotation, 5x lagging occured. The performance tracking shows a dipping of the curve when that happens (see markups on the the screenshot )

My understanding of these things is on a level where a photo of a block of cheese would be as meaningful.
I just store anecdotal things in my head and one of those things is that many many times Quadros have had issues with SU.
There are any number of hardware combinations that are possible, and one that works for one person may be awful for another.
All I know, fastest single core processor (meaning fewer cores but with a higher speed can be better than more cores with a lower speed) , plenty of RAM and a non quadro Nvidia card are a good start.

1 Like

What are the specs of your machine? The cpu brand, generation, storage and ram?

Your model feels quite responsive when opened in my ultrabook with a puny GeForce MX 250 mobile graphics “card”. Are you viewing it on a very large screen (4K?) with a large screen scaling factor? The P1000 is theoretically faster with its 640 CUDA cores compared to my 384 but still a bit “entry level” compared to current RTX cards. Still, I suspect there is something else going on. Even an extension could be the culprit.

My hardware is as follows:

Dell Precision 3630 Tower, x64-based PC
Windows 11 Pro, Version 10.0.22621 Build 22621
Processor: Intel Core i7-9700, 8 Core, 12MB Cache, 3.0Ghz, 4.7 Ghz Turbo
16GB 2X8GB DDR4 2666MHz UDIMM Non-ECC Memory
M.2 512GB PCIe NVMe Class 40 Solid State Drive
Graphic card #1: Intel UHD Graphics 630
Graphic card #2: NVIDIA Quadro P1000, 4GB, 4 mDP to DP adapter
Display DELL U3415W, 3400 x 1440, 60Hz, 8-bit depth RGB.

In the Windows settings, under System > Display > Graphics, I have set up Sketchup getting “high graphics performance” from NVIDIA Quadro P1000.

NVIDIA “manage 3D settings” is custom for SU. Open GL rendering GPU is set to the QuadroP1000 graphics card.