SpaceMouse - poor input performance (SU '22)

For those users who use a SpaceMouse, how has the performance been in SU '22, and even back to 20/21 releases? I’m finding that my larger models are beginning to really suffer when orbiting, specifically with the SpaceMouse vs mouse/keyboard. Updated drivers have done nothing and I’ve even had a fresh Win11 install since, which also didn’t change anything.

I can visually see the drop in FPS when orbiting, which is normal for me since I have large models. But the SpaceMouse becomes nearly impossible to use when things slow down and seems to become unresponsive. When this happens, I can easily orbit the traditional way with mouse/keyboard - while still noticing the FPS slowdown. There’s been some issues over in Enscape with users with 3dconnexion and their API integration and drivers. Figured it was worth a look over here to see how others are working.

And yes, I’ve cleaned my models and simplified where I can 'til the cows come home.

I have noticed a similar effect (I’m on an M1 MacBook Pro) significant difference in smoothness between mouse orbit and space mouse. I have found that it seems much more sensitive to receiver proximity placement.

I’m on MacOS with a basic corded model. It’s smooth and fast with a new model, but big ones do bog down. I didn’t know if that was a change or not. I might be crazy, but at times I’ve thought with big models, I get better performance if I move the cursor completely off the main SketchUp window, like onto my second monitor even. I’d be curious if others tried it and see if there’s anything to this.

It’s buttery smooth when navigating directly in Enscape though. It’s within SketchUp where something is wrong.

Since this would be on the 3D Connexion folks, have you contacted them about it?

I had been testing the same thing - moving the mouse off screen to see if that helps. Because it feels like it gets “stuck” focusing on an object or something, if that makes sense.

Took a cruise through their forums I found a few posts about poor performance - and driver delays etc etc. Zero improvement over multiple driver releases. It’s curious, because Enscape is having trouble with the latest API from them as well with the way they’ve chosen to integrate it into their software. So something tells me there are software woes over at 3dconnexion.

I’ve also been meaning to test out if the Logitech G Hub software is conflicting with the SpaceMouse software. (3Dconnexion is a Logitech company, for what it’s worth…).

Yes, but not always? It may be particularly when you’re in the middle of something like a push-pull operation when SU is also hunting for inferences?

No, just normal orbiting will get really janky and stuttery. Normal modeling operations don’t seem to be causing it. Seems more camera view related. Been hunting down in my models where the culprit might be. I’ve gone through a few times and made quite a few things more low-poly and it’s helped a bit but something is still “wrong.”

I also read a forum post around here about SU API calls that sort of feels like what might be happening…I don’t know.

Have you tried removing the 3DXware software according to the instructions on the 3d Connexioon site and installing as the directions indicate? I always right click and choose “run as administrator”.

I would suggest disabling rendering features that are “view dependent” - that is the amount of work that has to be performed by SketchUp depends on what viewpoint you have. Examples are:

  • Silhouettes
  • Realtime shadows

Yeah, I’ve tried installing in numerous ways. Admin, unzipping the package and only installing the SU .exe, etc. All the same result. It works fine in Enscape. Something’s up with SU’s performance.

If that is the case, something might wrong with your setup. If you are in the US try calling 3d Connexion. They have a 1-800 number on the website, and will try to get you fixed up.

Yes, the performance of the SpaceMouse is worst with recent Sketchup versions and big models, especially when you have certain tools activated, like the move tool.

This is maybe why this issue doesn’t happen when orbiting with the mouse, because in this case Sketchup switches to the orbit tool, which doesn’t look for inferences and isn’t trying to do anything else while orbiting (and it might be optimized for moving within the model).

I recently upgraded my computer from an old i7-2600K to an i7-12700K (with the same RTX 2070 GPU), and the much faster CPU (especially its single core performance) does make a big improvement within Sketchup. But if I have the move tool over some object while using the space mouse, it still studders a bit.

1 Like

Thank you for confirming this behavior. It does feel like the SpaceMouse fights for priority or something within SketchUp.Particularly when things slow down. My models are not overly complex, just large. And I’ve definitely noticed a decrease in performance over the past 1-2 releases in regards to camera FPS.

I tested by turning off my mouse but didn’t see any improvement.

I wonder if there is a way to watch a log file and see what’s happening live? It really feels like there is a process getting “stuck” or something- as I linked earlier.