Sketchup model rotating on its own with no input

My model is orbiting on its own without any input from me. I have attached a link to a video of me attempting to copy over a sink cabinet to a new faceframe and at the 25 second mark is when it orbits to a slanted top view of the area. Hopefully the link works.

I’ve disabled extensions, restarted SU, restarted my computer, went down to a single monitor and checked my mice to make sure there was nothing stuck in them.

I can barely work. Any suggestions on how to fix this?

Island Rev 2 - SketchUp 2024 2024-05-09 09-12-13.mp4

Looks like you hit ctrl while orbiting, which suspends gravity and it will tilt like that.

I’m trying to make sure nothing else is being pressed while moving objects. I can just sit here and watch it go crazy. It’s like someone else has control of my model.

Make sure the ctrl key isn’t stuck.

I see what you mean, but it doesn’t stop orbiting. Ugh. The Ctrl key isn’t stuck either. Thank you though. I didn’t even know about suspending gravity.

Could be your mouse itself, have you got another to try?
Have you spilt anything on your mousepad?

I will try unplugging my spacemouse and use just the CAD mouse and see if that makes a difference.

You didn’t mention the spacemouse, they can do this.

1 Like

I’ve had strange orbiting on occasion when the spacemouse got confused. From you image, it looks to me like you may be in parallel projection (parallel lines appear to be diverging)? I wonder if that is relevant…

1 Like

Sounds like the spacemouse is drifting, stuck slightly off center, it’s happened to me a few times. Usually just flicking the mouse input a few times cures it for me.

1 Like

OMG! It’s not orbiting anymore. I’ve made sure the drivers for it were up to date too. Wow.

Thank you Box. Maybe I should replace it? I really love the spacemouse.

Thank you very much.

I’ve also found that unplugging and then reconnecting a wired space mouse will clear this kind of issue. The equivalent would probably work for bluetooth, but I don’t have one to test.

1 Like

I’ve tried unplugging and reconnecting. Doesn’t help. I am actually working with 3DConnexion’s tech support. I’ll post the solution if they give me one.

Thank you though.

So in the end, the solution was to Stop the 3dXware from running, delete the 3DxWare\cfg file then delete the 3dConnexion folders from the Roaming and Local folders, then uninstall the driver, reinstall and then restart the computer.


It’s finally working properly.

Thank you all,

1 Like

I had a similar issue with my SpaceMouse. I contacted 3Dconnexion support and they sent me a replacement under warranty. You will need your purchase documents and they will probably ask for a video clip of the problem. Good Luck,

There’s a calibration that you can do within the advanced settings of the 3Dconnexion software. Like with gaming joysticks, the 3Dconnexion software needs to map the actual hardware values from the device to the software values that are sent to applications as “events” when you touch the device. The calibration will usually map-out a small range of values where the device is idle because the devices are so sensitive… You wouldn’t want the air blowing from a vent over your desk to affect the controller, nor even slight taps on a neighboring keyboard to cause the controller to vibrate a little. Make sure you do this calibration every once in a while.

Thank you for posting the fix…this happens to me as well but I just close SketchUp and re-Open it and it goes away…not sure if I want to go thru all that you did but I printed it out if it gets to driving me crazy…lol…

1 Like

Oh my gosh! It’s still doing it. Just not as often. I think I will ask for a replacement.

They also had me try a recalibration, a hard reset and test it on other devices. I don’t know. At least it’s only once in a while now.


Is yours wireless? (mine is wired) When I had troubles with my MX Master wireless mouse, some research turned up RF interference as a potential problem, and it turned out, mounting their little receiver on a USB extension cable fixed it. I’m not saying this is your problem, but now I know with wireless stuff, that can actually be an issue.

1 Like

No, mine is wired.

1 Like