Orbit becomes hard to navigate with mouse


#1

Hello, I’ve always had trouble with the orbit function while using the scroll button on the mouse. It will be working fine then all of the sudden it seems to be rotating from the wrong axis and I’ll have trouble getting to the perspective view I need. It happens in the middle of drawing a model and with different models of mouse and different operating systems. Seems I must be unwittingly hitting a button or doing something wrong… Any ideas? Thanks!


#2

When orbiting (same with zooming), is your move hovering on an object/face or in the empty abyss?
If so, then just have your mouse hover over something in your model since your movement is based on where your mouse is.


#3

Make sure you are working with correct model orientation.
Solid blue up, solid red to the right, solid green into the distance.


#4

Box has a good point. Also make sure the axes are in their normal default orientation. Realigning the axes to a model that is not correctly oriented does not fix the problem.


#5

Thanks for the quick responses! Tried both and still having problems. Definitely not ruling out operator incompetence…


#6

Does your mouse wheel have a side-to-side function and is it possible you’re hitting one of those? I’ve had experience with a few mice in which the CMB requires a lot of down force to activate it and keep it active. Is that a possibility?

It might also have something to do with where you are placing the cursor as you start to orbit. Could you try being very deliberate about starting with the cursor on the model and make sure it isn’t in the background somewhere? See what you get then.


#7

more specifically what’s happening… Let’s say I’m drawing a cabinet and I’m looking at the front view with correct model orientation(thanks Box) and I’ll click to try and orbit to see the right hand side of the cabinet and it rotates the whole model counter clockwise instead of bringing the right hand side in the view. Could it be hardware? Are some models of mice prone to bad behavior in sketchup? This one’s a logitech m325…


#8

Strange. I just “cut” the whole model, closed sketchup, then re-opened and pasted in the new sketchup model and it works fine… Wish I understood why that worked…


#9

Did you save the original file? Perhaps you could upload it or send it in a private message if you don’t want the world to see it.


#10

DaveR, did not save the original file. If it happens again, I’ll save it and have a more competent operator take a look.

Thanks all!


#11

Maybe your “cut” is just clipping issue and not actually cutting your model.

next time, take a screen shot