Mouse Wheel Stopped Orbiting

mouse
orbit
2018
scroll

#1

My mouse wheel has suddenly stopped orbiting when I click on it it, though it still zooms when scrolled. (I attempted to correct this through the “Preferences” menu, but there doesn’t seem to be a way to map shortcuts to mouse buttons, only keyboard keys?)

I’m currently using SketchUp Pro 2018 (upgraded in December). The Orbit function was working normally until yesterday - and because I was working on someone else’s project created in a previous versions of SketchUp I assumed it was a setting saved in that particular file - but now it won’t work in any Sketch-Up file I open - including new ones created using the a default template.

This is maddening, how to I fix it?


#2

This isn’t a SketchUp setting. Look at the mouse settings in the Windows Control Panel. What is the center button assigned to there?


#3

There’s nothing helpful in the settings.


#4

Does pressing the middle mouse button do anything in any application? There is always the possibility that it is broken. (Knock on wood) My present cheap Logitech mouse has lasted surprisingly long, but I have had several of its predecessors break, and the part that broke was just the middle button.


#5

Some mouse manufacturers have their own stupid drivers that by default assigns middle mouse button to other tasks, as if it wasn’t already in use by various programs. Maybe there is an icon in the Control Panel for entering the manufacturer’s own preference dialog.


#6

I assumed it wasn’t broken because the scrolling the wheel still zoomed in/out of the model, but I stole a coworker’s mouse for a minute and it works just fine.

Thanks!


#7

Is it a wireless mouse? Might just need a battery.


#8

The scrolling action and the switch when you press are usually separate mechanical parts, so it wouldn’t be surprising for one to fail while the other still works.


#9

I purchased a 3Dconnexion SpaceMouse Wireless last week. Everything was going fine, and then suddenly I started having the same issue… the space mouse works in all directions except it no longer orbits.

I launched the Trainer program and the Viewer program that came with the mouse and orbit works fine there, so this appears to be an issue with the space mouse and SketchUp.

Anyone else experiencing this? It seems my issue is identical to what started this thread, just a different mouse… and mine isn’t broken. I’m on a Mac running the latest version of OSX.

In an attempt to think of what else I was doing on my computer around the same time the problem started (looking for correlations of possible software conflicts), I had launched Adobe Illustrator and done some work in there.

Thanks for any thoughts/help/suggestions!


#10

Restarted Mac and it worked again!


#11

I had that problem too. My mouse buttons changed after I “re-unified” my M705 Wireless mouse and K360 wireless keyboard (both “logitech” hardware).

I used the latest Logitech “setpoint” software (free download) to set the scroll wheel function to “other” then “select function” button then I chose to use it as a “Generic Button” . . . My mouse returned to previous button functionality.

Hope that’s helpful for you . . . or anyone else.


#12

Thanks emanon211. That worked for me.