Problem with orbit command

Hey folks, Is the middle mouse button orbit feature native to Sketchup or is it a setting that can change? My mouse quit orbiting with the middle mouse button after my 23.1 update. Coincidentally, my space mouse with latest driver will zoom but wont orbit or pan. When I click “O” my orbit works with the left mouse button just fine. Are my mouses broken or did I fudge a setting somewhere? I appreciate the feedback.

It’s a native feature in SketchUp and there’s no setting within SketchUp to affect that. Check to see what the middle button’s assignment is in the mouse driver settings.

@DaveR is right that unless the mouse button has failed, the problem is most likely that the OS isn’t mapping the button to the event SketchUp is looking for. Check the mouse driver settings.

Regarding the space mouse, I’ve seen similar things when the 3DConnexion plugin isn’t being loaded by SketchUp. Try downloading a fresh copy of the 3DC driver and reinstalling it.

Thank you Steve and DaveR for your response. I had updated my 3dconnexion driver but per Steve’s suggestion I deleted and reinstalled the driver and my space mouse is working its magic again.
My old Amazon Basic mouse still doesnt work with the middle mouse button. After reading Aaron’s book, I ordered a new Logitech MX Master mouse. Now I can quit blaming my tools and get to work.