SU2023 - Orbit tool - unexpected auto zoom

The middle mouse button / orbit tool is acting unexpectedly. Instead of orbiting, it’s orbiting AND zooming out simultaneously. SU2023*

1 Like

What kind of mouse? Can you reproduce it? Record a screen capture of it happening? Give steps to make it happen? I haven’t seen and odd navigation issues on my PC with 2023 but maybe I haven’t done the same thing you have.

I may just need a new mouse. I’ll make a clip, please hold for that.

I made a clip of what I’m seeing. Too big to upload directly. Might still be processing.


It’s probably just my mouse. I can’t get it to replicate the issue every time. It’s just once in a while. I’ll try another clicker. Thanks.

1 Like

Good luck.

I used to have to use SketchUp on a school computer with a school-supplied Microsoft mouse. The CMB action was much stiffer than on the Logitech mice I normally use. It made orbiting and panning very challenging. I finally started bringing in my own mouse when I’d teach so I didn’t have to climb up on the lectern to get my entire body weight on the button.

I have a Logitech MX2 wireless mouse. I find that turning off the middle wheel “clicks” leads to performance like you describe, as, at least for my clumsy fingers, it is impossible to click the wheel button without simultaneously spinning the wheel.

hi same trouble here.
i’m using a Microsoft Bluetooth Mobile Mouse 3600.
with two axis wheel (middle botton).
every time I use the wheel, I click unintentionally to the right or to the left and activates the zoom out
how can i managed/fixed those clicks from my mouse?
because there are no options in the settings.
thanks for the answer.

Curiously I do not have an issue with my MX Master 2, it is set for free wheel.

It is probably just a matter of manual dexterity. I am quite unable to click the wheel without simultaneously turning it when in freewheeling mode.

Any solution to this?

I have the same problem. This is not a mouse problem. It started to show after upgrading to 2023. Here is comparison of orbiting with mouse button on 2023 vs 2022 - it works only on 2022. On 2023 it starts to zoom randomly while holding.

It seems that if it was a SketchUp problem everyone would have the same problem. Not everyone is, though. I’ve never seen what your video shows while orbiting in SketchUp 2023.

If it wasnt SketchUp issue, it would show in both versions + in other applications.

Since this is showing:

  • only in SU2023 (compared both 2022 and 2023 open at the same time on the same PC) and
  • not only on my PC

Therefore it is not a hardware issue and it does not show only on my setup. I would guess and as a gambler i would bet my money on the option that it is most likely either some sort of SU2023+OS or SU2023+hardware issue. But it started to show after updating to 2023, installing 2022 again is a workaround.

Is this fair conclusion?

If not, please explain, because i do not follow how did you arrive at your conclusion.

The 2023.0.1 release notes includes this entry:

  • (Win) Fixed an issue when pressing the ALT key and zooming with the scroll wheel.

Does the auto zoom happen if you update to 2023.0.1? The installers are on this page:

Hello Colin, Thank you. Yes this is the version i am using: SketchUpStudio-2023-0-397-152

Found the reason. Apparently 2023 does orbit on wheel press and does zoom in and out on scroll left/right (logitech M705). I do move and press it sometimes when orbiting.

2022 does not use this function so no problem there.

Since i do not use this mouse buttons anyway I used AutoHotkeys to disable this in mouse with code:
(updated to add shift combination)

Shift & WheelRight::Return
Shift & WheelLeft::Return

This way 2023 works as desired. Thank you.

The function of the center mouse button and wheel is the same as it’s always been. scrolling the wheel zooms in and out, pressing the center mouse button activates Orbit. It’s been that way for more than 20 years.

You are correct and I do not mean scrolling.

I mean pushing the wheel to the sides:

wait, your wheel does that ? then yes, it might be seen by SU as a conflicting command.
weird enough, My logitech master mx2 has a lateral wheel (on the thumb), and SU doesn’t care. So what you noticed only affects the main wheel ? could it be because of trackpads ? when people use two fingers on a trackpad, like a mousewheel, they tend not to swipe up/down but more in diagonal. Right handed people will swipe top left - bot right.

It seems like a legit command both for my mouse and for SU 2023.

I can control the Zoom In/Out step by pushing pressed down wheel to the side when orbiting. Apparently it is also triggering when moving mouse around with wheel pressed.

I work on PC.

Yes i have only top/main wheel with side moves and after i disabled them in Autohotkeys it does not zoom in or out anymore.

Interesting. I can’t say I’ve ever moved the mouse wheel to the side accidentally. Have never used that function in SketchUp. I didn’t find that it has any effect in SU2023 but now this has got me thinking about possibly adding that to my workflow.