Middle click not orbiting correctly with Logitech G600

I’ve been using Sketchup for many years and have recently encountered a new problem. I bought a new mouse (Logitech g600) which has generally been great. It has 20 buttons that I can map shortcut commands to so that I don’t have to use the keyboard as much.

However, using the center wheel to orbit does not work as it’s supposed to. It always suspends gravity as if I’m hitting the ctrl key at the same time. This is not an issue of the axis settings. The mouse behaves this way in all of my sketchup models. I’ve also tried old mice and they work correctly.

Furthermore, If I use the orbit command I can orbit normally with the left mouse button. I’ve also tried mapping the middle click command to other mouse buttons and that doesn’t work at all.

I’m wondering if anyone else uses this mouse for sketchup and if you’ve run into this issue.


Double check in the Logi software that it is mapped to middle button.

The Logitech software says that the middle button is mapped as “middle click”

Does the scroll wheel have the left right tilt action?
Some mice have the ability to scroll, middle click, and tilt left and right all on the wheel. Normally used for Back and Forward and such, you may not have noticed it and it could be causing the gravity well when you click.

Yes, it does have the tilt action. I have those mapped for undo and redo. I had the same thought you did and I’ve tried to tilt and orbit at the same time to see if that’s the issue but it’s not.