Mouse wheel misbehaving?


I’ve tried searching this forum (and the rest of the web) for an answer, but can’t seem to find what I need…

When I press the mouse wheel down to orbit, it does so, but also simultaneously zoom out. Initially I thought Id just put up with it, but it’s much more annoying than I’d imagined it would be!!!

Doubt these will work… but maybe…

Any ideas?

What mouse do you have? Is the driver software configured to use the wheel as the middle button?

Lots of scroll wheels on mice are also buttons - if you push them in they are a 3rd button.

I imagine if you are pressing too hard that is happening - perhaps it’s a little worn and is looser than previously?

1 Like

Have you tried this with another mouse?

Thanks for the replies everyone!

Yes, it’s the same mouse I’ve used with SU 2019, 2020, 2021, and 2022 without a problem.

Can’t see why it should suddenly do this. Plugged it in to the workshop laptop which is running 2020 still, and it works fine, so it has to be SU2023?

I’ve got 2023 installed on a Windows machine at work, and I can’t seem to create the error you’re seeing. The only way I can kind of make it happen is if I try to move the scroll wheel while pressing down on it to enable orbit. I even tried a different mouse, but no issues there.

There were a couple of other users with the same issue too, seems to be something going on,

Try changing the autodetect to click-move click and see if that helps

1 Like

I had a similar problem. A reboot fixed it for me.

Hmmm… puzzling.

I was just about to suggest that maybe having turned the computer off for the day will give it some time to think about its actions, and tomorrow it’ll be fine :joy:

Cheers @Elmtec-Adam, I’ll try that if the reboot doesn’t cure it.

Thanks again for the assistance!

1 Like

Just guessing (because this has been the culprit in the past), but is your middle button click assigned to “middle button” or “scroll wheel”?

It should be “middle button”

Thanks for all your help… I’ve just tried a third mouse, and that seems to work fine. So no idea what was wrong with the first two.

Never mind, and thanks again!

1 Like