Orbit with mouse wheel stopped working - not the mouse

Hello - was working on a model successfully pressing the mouse’s scroll wheel to orbit. All of the sudden, it stopped working. I have troubleshot in the following ways:

  • The wheel itself still functions for zooming.
  • I tried another computer and another mouse. Had the same issue.
  • I tested the mouse independently to ensure the scroll wheel button is still function. It is.
  • I’ve searched other forum posts but they all say to “get a different mouse.” I don’t buy that because it was working successfully for around the first 2 hours of my project, then stopped suddenly.
  • I can still switch to orbit with the ‘O’ shortcut. But that’s a pain.

I am using Windows 10, Google Chrome, and the Free version of SketchUp that has no preferences menu. It was last updated on 1/28/2020.

Thanks,
Scott

I just tested Orbit here in SketchUp for Web and it’s working for me.

Is yours a wireless mouse? If so, how long since you put fresh batteries in it?

Have you tried the long standing Windows fix for everything? That is reboot the computer?

I have the same problem with Win 10 and SU 2020!

No, both mice I tested were wired USB 2.0.

Also tried creating a new project with 2 different mice and the orbit still doesn’t work.

Look at the mapping for the center mouse button. How is it labeled?

You said before that the wheel still works but have you tested the switch underneath the wheel? It’s unlikely that two mice would fail in the same way at the same time although possible. More likely it is the mapping of the switch in the mouse settings.

Have you tried using SketchUp in a different browser?

This is in Chrome on my computer using the center mouse button for orbit. I just open SketchUp in the browser to test it. Clearly SketchUp seems to be working fine in the regard here.

UPDATE:
I used this online mouse button testing website and confirmed that the center scroll-wheel button was not firing with either of the 2 mice I tested with. https://www.onlinemictest.com/mouse-test/

So I tried a 3rd mouse, and it’s working. So I guess it WAS the mouse after all.

I’ll mark this thread resolved.

Thanks all for the help and suggestions.

Interesting. What are the chances that two mice would have failed in exactly the same way at the same time? Are they old ones? At least the problem is solved.

I know, right? Both probably a year old with moderate use.

Maybe time for a better mouse? I have a Logitech M510 wireless mouse that gets hard use every day. It’s at least six years old and still going strong. The bottom is kind of wearing thin but all the buttons still work fine. It’s the one on the left. The one on the right is about two years old and only gets occasional use.

All the failed mice I have met have had broken scroll wheel buttons. Probably the engineers designing them failed to see how much SketchUp and CAD users would come to rely on that and made it less durable than the left and right buttons. Admittedly the part is also more complicated than a simple button.

1 Like

No, there is definitely some sort of hang up. I’m creating screencast lessons for students using SUF and after while, the scroll wheel simply stops responding, no longer letting you zoom. I am using Chrome on a Mac, but the same behavior happens with Safari.

My mouse is new and I know it is not the mouse as if I duplicate the tab in Chrome, which reloads the model, it starts working again, for a while.

Not is Sketchup, I am having mouse issues with it loosing its settings no matter what I am doing.