Orbit tool used to rotate around where I 'clicked', now it rotates around the centre of the screen

I am using Sketchup Pro 2017 on my Mac, and after many years of using sketchup the orbit tool functionality has changed on me. I just updated my OS, so that could be the issue, but if anyone has any suggestions they would be much appreciated.

Originally, orbit has alway rotated around wherever I clicked the mouse, however now it seems to orbit around the centre of my screen. This makes navigating very difficult. If I hold ‘option’ while using the scroll button on the mouse it orbits correctly, but when using the orbit tool, or the mouse scroll button without holding ‘option’ it defaults back to orbiting around the centre of the screen.

Any thoughts?

Clearly SketchUp 2017 Pro hasn’t changed in about 4 years but it could be an OS related thing. Maybe a mouse setting? What kind of mouse? Did you update its drivers?

Please complete your profile with SketchUp version and current operating system.

Thanks for the quick reply. I just updated my profile.

The mouse is a Logitech G602 and doesn’t appear to have any drivers available, but I don’t think it is mouse related because I get the same issue with the trackpad (Normally I only use my trackpad, but it is too hard to hold the option button while using the trackpad).

Are you sure you haven’t tilted your workspace? I’m not a Mac person, but I think Option with orbit should be suspending gravity, so it sounds like you may have turned everything on it’s side. The solid blue axis should be up, and check if the axis has changed by right clicking on any one of the axis lines and see if Reset is available.

1 Like

That solved it! thank you @Box! I can’t believe that I have not run into such a simple fix in all these years. Cheers

Many people use all white backgrounds, I have no idea how, and they can get easily disorientated. I personally always have a horizon visible in any modeling mode.

What was it? The axes were rotated?

FWIW I’m one of those who work with an all white background but the axes are always visible and I don’t have any trouble keeping track of which way is up.

When I created my model I began with the wrong axes up. I had the dashed green axes vertical compared to my model, so when I attempted to orbit it didn’t perform as I am used to. Once I rotated my model and my camera to have the solid blue axes vertical it solved the problem.

1 Like

Ah… That’ll do it.

Thank you both for the quick help!

1 Like

Great spacial orientation Dave- are you an astronaut? :rofl:

Without the axes being visible, I can’t make orbit behave properly. So they’re always on.
Axes off-on is under the VIEW MENU.
I turn them off prior to printing as they do get printed.