Lag issues on SU models at around 250,000 KB and even worse when importing into Layout?

Hi, I’m getting a lot of lag in SU on models at around 250,000 KB. When I do anything I get a delay of about 3secs which quite often increase to 30secs and more whenever I click the mouse. This is hugely frustrating and then gets even worse when I import the model into Layout. I thought my pc was up to and over the requirements, please see the following spec -

Operating system - Windows 11 (just updated)
Graphics card - NVIDIA GeForce GTX 1050 Ti
Processor - Intel(R) Core™ i5-9400 CPU @ 2.90GHz 2.90 GHz
Installed RAM - 8.00 GB (7.81 GB usable)
System type - 64-bit operating system, x64-based processor
SU 2019

I’m thinking about moving over to Apple with a heavy investment to improve this situation as its driving me crazy and really slowing up my design time.

Please help!!

These kind of delays are typically related to the throughput of the graphics card. Make sure the graphics drivers are up to date. Go to the Nvidia site and get the latest drivers to install. Don’t rely on Windows to tell you if the drivers are up to date.

A 250 Mb file is pretty large. Maybe it could be cleaned up. It would be interesting to see how your file performs on a different computer. Maybe you could share it. That would help us help you.

There have been performance improvements in SketchUp and LayOut since 2019. Maybe you could get up to date.

Before serously considering switching to Mac, you should make sure your modeling is efficient and clean. That’s usually where you’ll get the best performance improvements. Without seeing your model yet, I’m going to guess that switching to Mac won’t help.

Really very helpful DaveR, thanks. I’m happy to share if you can tell me how I get the file to you?

It’ll be too large to upload here as it is. Upload it to Drop Box and then share the link. If you don’t want to share it with the entire world, send the link to me in a DM by clicking on my name at the top of this post.

Just sent you a DM.

Got it.

A 250 MB file has probably so many edges and faces that it will be slow whatever the computer specs and SketchUp version. Purge it. Use simpler entourage components.

Thanks for your help Anssi, I do purge on a regular basis to try and keep the model streamlined. The model has 849 component definitions, 12 edges and 0 faces. I’m unfamiliar with ‘simpler entourage components’ though? This sounds like something I could try, tbh I’m happy to try anything…

You see the true edge/face count if you tick the “Show nested components” box on the Statistics window. 12 edges can define a single cube.
image

The 3D Warehouse is full of 3D components like plants, cars, people, upholstered furniture etc. that are very high polygon, and cannot be used in big numbers in SketchUp models without bogging them down. A case in point that I remember was a model I saw some time ago: A rather detailed tower apartment block where about 95% of all the edges and faces were contained in a niceish creeper plant on a small portion of the façade.

Well in that case, my model has 3196098 edges and 1543700 faces!!! Wowzers, haha.

Yes I’d noticed that when I import components from the Sketchup Warehouse it quite often slows the model down immediately. I layer everything in the model and hide the layers that have the components in that I don’t need to see until the end render stage. I assumed that by having anything hidden away in a layer that I didn’t need until a later time that this would speed up the model. Is this not the case?

You should try not to make it any bigger. When modelling, use a style with Profiles and Shadows turned off. Also check the size of your material textures, 250MB with these polygon numbers make me suspicious.

So I’m looking at your file now using SketchUp 2021 on an older Nvidia graphics card. I’m not having any trouble navigating around the model and I don’t really see any lagging.

There are some things you could do to improve performance, though. First of all you really shouldn’t have your model strung out across the county like this. You could create all the scenes you need of the individual cabinets without the extra copies floating in space.

With appropriate component/group nesting and tag usage you should be able to create all the scenes you need of each cabinet without having more than one instance of each one. I deleted all of the unneeded copies of the cabinets and such which reduced the file size by more than half.

You have a lot of 3D text in your model that adds a lot of “weight” to it relative to the benefit it provides. You’d be better off adding the text in LayOut instead.

As for the heavy entourage, a good example is the Hafele wire racks. Lots more geometry than they need to have to communicate what they are. You could reduce the geometry by half and still have more than adequate representation of the product.

Every wire in the rack component has a centerline which really isn’t useful but adds to the load. It’s a cost with no benefit.

The dining chairs and the lights over the table are also rather heavy components and could stand to be put on a diet, too.

I fixed the incorrect tag usage.
Screenshot - 12_21_2021 , 11_29_07 AM
And purged unused stuff. Your model was fairly well purged but it could use a little more.
Screenshot - 12_21_2021 , 11_29_32 AM

I expect you could eliminate another 5 of the remaining 7 styles. They all look the same anyway.

LayOut will also still be slow with this model because of all the excess geometry.

So going back to the end of my original post, I think before you throw money at new hardware, it would be beneficial to look at improving your modeling process. As @Anssi indicated also, whatever the computer specs, your modeling process will have more impact on performance.

Are yo able to advise on the best defult style? How do I find out the size of my material textures? Also, do you know why when the model is in Layout its so slow?

I think @DaveR summed it up pretty well. The heaviness seems to affect LayOut exponentially, especially if you use Vector or Hybrid rendering. Raster rendering is more forgiving. You can also reduce the load by setting LayOut Display quality to Low while getting decent PDF output by setting Output quality to High. When exporting raster-rendered LayOut files to PDF, do not use JPG compression for images, it causes very ugly output. JPG compression works only with photographs. If the PDFs become too big, they can be better reduced by using a PDF editing program like Acrobat or PDF Xchange Editor.

1 Like

For in the way of entourage: Do the sink strainers and the auxilliary drains add important information in your model? Maybe you could eliminate them. Maybe you could simplify the plumbing fixtures.

The chairs should have their face orientation corrected.

These are things that should be done before you add the components to your model. The standard wisdom is to download entourage into a separate SketchUp file to clean up before you add it to your project.

You might find an extension called SKIMP to be useful as it will quickly reduce components for you.

There are some extensions such as Statistics Probe which can give you some ideas about what in your model needs attention.

There seem to be a whole lot of book and container components in your model that have detailed cover images that don’t really show in the model. Do you really need the entire label including ingredients, nutritional information and UPC code for a can of baby corn?
Screenshot - 12_21_2021 , 12_20_45 PM

There’s lots of this kind of thing that is also causing you a huge performance hit without really adding anything useful in the model. Think about the cost-benefit equation for everything you add to your model.

Look through the materials in your model. Do you really need a texture image for the top of a can?, a top down view of coffee in a cup? Two images of a ketchup bottle? 6 identical leaf texture images? Images of floor lamps, knives, perspecitve photo of beans in tomato sauce, remote controls?..

1 Like

It would be if you modelled the thing anew with fewer segments in a circle. I bet they have the default 24 while the thin wires could quite well do with 5 or 6.

1 Like

True. And once the new, simpler “wires” were created, the centerlines could be deleted.

I’m not trying to pile it on but here’s another thing. I exported the texture image for the baked beans. It’s 2.73 Mb. That’s a good example of something that “costs” a lot without adding any real benefit.
Screenshot - 12_21_2021 , 12_36_50 PM

These are some really useful points, thanks so much both I’ll act on this straight away. I’m aware that by doubling up the cabinets to create the scenes I need of each, I was making the model larger. I’m having trouble when I don’t double them up though, when the model is exported to Layout sometimes some of the geometry from the rest of the model gets in the way or appears in the image on Layout. This is why I do this which I know makes the model larger but creates a clean image to be sent to Layout. Perhaps I’m not making the scenes properly as I’m sure this isn’t supposed to happen.