SU 2024 problem with log in


I just upgraded my SketchUp Pro to 2024. It was working perfectly before the upgrade, but now I’m getting this message:

“You have exceeded your allowed activations.”

To continue, I need to sign out of SketchUp on other computers or use the provided link to sign out of all previously authorized versions. I’ve already signed out of SketchUp on all my computers. Additionally, I clicked “Deauthorize All” in Manage Devices, but the issue persists. I’ve even restarted my computer, but after 50 minutes, I’m running out of options. Can anyone help, please?

hello, once sketchup is launched, log out (from sketchup, not browser) and log back in again

I seem to be having the same issue. It stopped me for opening all files even with the 2023 version. I uninstalled version 2024 and managed to relink files back to the 2023 version to get me back up and running again.

Did Pauls answer help matters?

it does if before doing what I suggested, you deauthorize all devices on sketchup website from your account just like @OLMI seems to have done

After many attempts, it is finally working. @hilltop_watt, did you deauthorize all accounts (if you have more than one)? That was my issue.

For anyone who has installed 2024 and are now going to try it, open the version you were already using, and sign out from within SketchUp (from the Help menu would do). That will free up the activation for 2024 to use, and you shouldn’t get the too many authorizations message.

1 Like

Thank you, I think I have got it sorted out now.
Just loading extensions etc
All the best

Can we not have both open for testing etc?
It usually takes me weeks to fully migrate all projects , extensions, etc.

It would be great if the Trimble Identity manager showed the computers that you’re logged in to, and then allow you to force a log out of those.

1 Like

you can, you have 2 activations at the same time.

Got the very same problem here. De-authorized all devices. restarted the computer, threw away skup 2023 including the library app support but still get the message that’ve exceeded my allowed activations

You didn’t say whether you have also signed out and signed in again. Try doing that, and if you’re still seeing the message when you reopen SketchUp and sign in again, there is a session file you can delete to give SketchUp a fresh chance.

To get to the file to delete, choose Go to Folder… in Finder, and paste in this path:

~/Library/Application Support/SketchUp 2024/

Drag the file login_session.dat to Trash, and reopen SketchUp. Try signing in again.

1 Like

I’m getting the same issue between 2023 & 2024. I have already deactivated all a couple times and have no other instances of SketchUp running on any other machine. Seems like whichever one I sign into second sticks and logs the previous version out (like 2024 with 2023 or 2023 with 2024). Then repeating the process to sign back into 2023 logs out 2024. Rinse and repeat. Should I submit a bug fix, @colin ?

If you have done the deauthorize all devices steps, and you’re back on this machine, you should be able to sign out, close SketchUp, reopen SketchUp, and sign in again. If that doesn’t work you can tell support about the problem here:

1 Like

Thank you Colin,
I did signed out but probably in a proper order between the app and the website. This is tricky.
But now it works perfect. Must have hit the right order.
Thanks again Colin

It is definitely not intuitive.


1 Like

You mention one thing worth pointing out: No amount of signing in or out of any SketchUp or Trimble web sites, directly in a browser, will help. The only sign in or out that is needed is the one triggered from inside SketchUp.

This should be easier to do.

1 Like

PC users. Do this in addition to signing out of everything Colin Listed above. It worked for me

  1. Close all instances of SketchUp and LayOut. To make sure they do not continue running in the background, please go to your Taskbar and right click on any SketchUp or LayOut icons and select Close Window.

  2. Open Windows File Explorer and make sure show hidden files/folders is enabled (learn more | View hidden files and folders in Windows - Microsoft Support)

  3. In File Explorer, go to Windows (C:) > Users > your user name > AppData > Roaming > SketchUp [year] > SketchUp (C:\Users\username\AppData\Roaming\SketchUp\SketchUp[year]\SketchUp)

  4. Locate and delete the “login_session.dat” file

  5. Restart SketchUp and login

1 Like

I have tried all of the above to no avail. I recently purchased a new computer and I am trying to migrate all of my apps to the new one. I need SketchUp 2023, not 2024 because of plugin compatibility. I tried signing out of SketchUp on the old computer at the sign in page and even in SketchUp its self (from the help menu). I tried deleting the login_session.dat file. I tried clearing cache and cookies. I tried opening the Task Manager to ensure SketchUp is not still running. Nothing works.

Ok, I solved my problem. I had to log in to the Trimble ID account, go to My Products, Select the SketchUp Pro, select View Included Applications, click Manage Devices on SketchUp Pro, and Deauthorize All. For good measure, prior to trying to open SketchUp, I deleted the file mentioned above (login_session.dat).