Styles overriding themselves

Ummm when is this bug going to be fixed? This is crazy!!! The styles keep pulling in settings like Xray, Hidden lines, Hidden objects, Turning on and of section cuts, Section fill…etc…I did NOT change the style but somehow it has altered itself. If this is the way the Sketchup Team thinks this should work they should lay off whatever they are smoking. PLEASE FIX THIS ASAP. Got yelled at by my boss because I did not notice that my exported sections had lost the dang section cut and fill setting. They were just elevations…This was not the case in I would like to say version 2020? 2021 had it and 2022 for sure has it.

Going on 2 years now. I think that is ample time to fix a bug that did not exist before.

Can you share a SketchUp file that does this? I’ve never seen styles change on their own. I’ve seen plenty of cases where users haven’t updated a style when making a scene or when users have set up scenes to not save the style when created.

I understand how frustrating this must be, but at least entertain the idea that there is something in your workflow that is causing this. Styles magically changing themselves for no reason has never been a problem, not five years ago, not two years ago, not today. The good news is that there is probably a clear reason this is happening with your files that you can learn about and then never experience this again (most likely just a misunderstanding of scene use and/or style updating). If you include a file that has changing style qualities we can have a look at your setup and figure out why you are seeing this.

I have two styles. Standard and Section. One has shadows and one sections/fills. I do not have any add ons other than cleanup 3,ttlib and instaroof. I don’t think these should be overriding style settings. I am uber clean and simple. I have watched it happen. I hit X-ray to snap to a line and then X-ray somehow got saved into a style setting. Is there any command which autosaves the current state into the style? I thought the only way was when you click on the 3 arrows in the style box over the current style. By the way I am on a Mac.

Thanks,
Betazero

I have been using Sketchup for 14 years…and yes your right up until 2 years ago this behavior did not exist.

Well that is not quite what I was saying, I meant that it has never been a problem that I know of and is still not a problem I have ever heard of. I’ve been using SketchUp for a while as well. Unless there is some very unique situation with your setup (extension conflict?) that makes you the only person that experiences this style spontaneously resaving behavior, then there is something in the way you are working that is causing this. I am skeptical that it is a bug. Perhaps if you shared one of your files that exhibits this behavior we could have a look it and discover a reason it happens to you.

1 Like

Ahh ok well it is now and has been for 2 years on I guess my 3 unique Schizo Macs using the most basic styles possible. What are the things which can override styles? If the only way is the button then it a bug for sure. I will share one tomorrow but you would have to work on it for an hour or two for it to happen. It doesn’t just happen all then time but a good 6-8 times in a day is driving me crazy. It has happened on multiple ski files too by the way.

There’s not much point trying to troubleshoot what your issue could be until we have ruled out a setting in your template that may be causing the issue. So without seeing a model there is no way to move forward and help you.

2 Likes

My template? I use a standard Arch template… I am going to record it happening. It just happened twice with latest and greatest 22.0.353. I put screen record on and tried working again and then it did not happen. I need to just record until I forget I am recording so it happens. Do you use the Mac version?

Yes I use Mac. If it just happened, upload that file.

Here ya go. Watch at 3:55ish. I double clicked to edit a component and the style was saved…

link to movie - > Movie

hidden line and sections off were saved into my style…

I saw the style update around 3:55. Couple of questions: Open SketchUp>Preferences>Shortcuts. Type in “update”, what is View/Animation/Update Scene set to? Also try Preferences>General>Reset all Warning Messages, it’s possible you have the pop up window that warns of updating styles turned off. Can you post your file here so we can see how it’s structured? There is a reason for this behavior, either on your machine or in your workflow.

Its set to nothing

That’s not what he is referring to. Warnings are in preferences.

If I had to guess, I’d say your scene settings do not have all parameters checked to save.

There is no bug, that I’m aware of, that will change a scenes setting without user input or if the parameters to be saved by scene are not checked. Any parameter left unchecked will default to the current work space.

I reset all warnings and it still does it. All scenes save all settings.

Oh well it exists so yea in every SKP file it does the same thing. There is not one that is not doing it. This started 2 versions ago. Yes there is a bug that is overwriting the scene settings.

Thanks,
Russell

Maybe it’s your install? If it were a bug, it would be happening to more people. I’ve never seen this before.

I have to agree with @Sonder that something odd is going on with your setup specifically. Yours is the only case of styles spontaneously updating that I have ever heard of in any year version. It seems unlikely that this is code bug as it does not seem to be happening to any other user. Could be an extension interaction? Maybe check your active extensions and disable any that you are not sure of.

I have to disagree since this happens on multiple SKP files and I dont use any plugins other than TT_lib, Cleanup3 and Vali Architects roof thing. Very simple and very clean. I only have 2 styles present in my drawings. If you could tell me what possible things could overwrite a style while double clicking on a block then sure maybe its not a bug. But since it happened in the video and multiple times per day doing just random things it is a bug. It also happens on 3 different Macs. I really hate when people say something isn’t a bug like the NLS warnings in Autocad when exporting DWGs from Sketchup. This problem has been around for FKng YEARS …like 6 (and this is suppose to be a “PRO” feature…) and I think finally in 2023 Autocad is fixing it. I have sent in multiple requests to Autodesk and Trimble to get this fixed…This problem with the styles started 2 years ago and did not exist before that. Also, the current performance of Sketchup sucks compared to last year. There was a patch that brought it a bit back to 2020 level but there is a lag that did not exist before.

So this problem has been around for years? If it is only you having this issue, it is unlikely a software glitch. Using SU and LO as much as I do, it would have certainly reared its head once or twice.

If it were me, I’d do a full uninstall/reinstall as administrator.

2 Likes

OK. I’m trying to be helpful to you and approach your issue rationally. In many years of using SketchUp and actively helping people understand it, I have never experienced or heard of anyone having styles updating themselves spontaneously. I’m not perfect, it’s possible I missed it, but I pay attention and have never heard of it. Perhaps this thread will bring out someone else to corroborate your experience and we can get some more information that way. But for now, if it is a “bug” it’s one that only you have. So whatever you want to call it I would think you would be interested in solving the problem, which would involve more communication experimentation and brainstorming. I feel like you are adamant about calling this thing happening only to you a “bug” because you don’t want to try to fix it and would rather believe that it is someone else’s responsibility. If so, then fine, you may call it what you like, but as you are the only user having this problem, it’s unlikely that Trimble will be motivated to “fix” a problem that does not happen to any else. In your own self interest, you might at least consider the idea that something is wrong with your setup. Or not, do what you think is right.

I have not experienced the increased “lag” you refer to. I find SU and LO 2022 to be snappier than previous versions, and a general improvement. I wonder if there is some sort of disk permission issue or installation issue that corresponds to the decrease in performance you are experiencing dating back to 2020. As you are on a Mac like me, reinstalling as administrator is not relevant here as that’s advice for repairing windows versions. Where is your SU app stored on the hard drive? Are you using a cloud service for any aspect of your work? Is it possible you’re running SketchUp from the downloaded disk image rather an installed version? You reset the warnings in preferences, and it still happens without a pop up warning window appearing? Just some questions searching for an answer to this unique problem. If you do not want to continue trying to solve it, no problem, all the best regardless.

2 Likes