Edge settings not being saved in style

Recently my edge settings got disabled in my default style so now whenever I open a file or create a new one my edges and profiles are turned off.

I went into the default style I am using and ticked the boxes to re enable them, clicked the update style button, saved the file and re opened it but my edges and profiles were still off.

Perhaps I’m missing a step but I can’t seem to get the settings to persist between instances. I’ve tried looking for similar topics here but they were either slightly different or the solution didn’t work, please help.

Did you save as template? Or did you just hit Save?

If you want to fix your template’s style, you need to use Save as template. And make sure you select Use as default when doing so.

I’m using one of the default styles that comes with Sketchup. Is it not possible to restore it rather than creating a new one?

Edit: What if I want to switch to one of the other default styles, how would I force Sketchup to use one of them when creating a new file or opening an existing file?

Is it a style you want to correct? Or is it the style in your default template?

You could replace the style that came with SketchUp if you want. You would need to save the style to its normal location, then.

You can select a different style or a different template.

Are you still using SketchUp 2013 as indicated in your profile?

Yes, unfortunately I still have to use 2013. I used to also have 2015 installed but due to the way Windows handles file associations it became too much of a pain to have both installed.

It seems there’s a larger issue here than just edge settings. I can’t seem to get any styles to save or apply. I’ve tried selecting and editing existing styles and creating a new template but none of them apply. Every file I open or new file I create uses the broken style.

As I recall (2013 was a long time ago and things have changed) the location for the styles that are included with SketchUp 2013 is in Program Files and Windows 10 has that locked up normally. You would need to edit the security permissions to allow writing to the folder.

Why is that?

Newer versions of SketchUp have a better way of dealing with file locations for styles and templates.

Including older files? If that’s the case, I’d be looking at graphics drivers, not the style setting. Make sure that SketchUp is set to use your Radeon card instead of the integrated Intel graphics and that you have the latest drivers installed. Don’t have Windows tell you if you have the latest. Go directly to the Radeon site and check manually.

Also you should keep in mind that SketchUp 2013 does not explicitly support running on Windows 10 since it was released more than 2 years before Windows 10. There could be other issues.

I primarily make meshes for IMVU and the last I checked, the latest exporter only supported 2013. There was one that supported 2015 but I don’t agree with the authors terms of use and find it to be less convenient.

IMVU now supports the FBX format so I’ll look into whether or not newer Sketchup versions either support that natively or have plugins available. Or maybe write my own plugin when I get the time to sit down and learn.

Yeah, even older files. I do not currently have the latest drivers installed however this is a problem I’ve been dealing with for almost 2 years now and I’ve gone through many GPU drivers since then. Where would I check to make sure Sketchup is using my GPU? I only see OpenGL settings available. Or are you talking about creating a profile in my Radeon Settings?

You should look both in SketchUp’s OpenGL settings as well as your Radeon settings.

You might also try turning off Hardware Acceleration in SketchUp’s OpenGL preferences and see if that changes anything.

Disabling hardware acceleration didn’t make a difference. After some further testing it seems changing a style and saving the file does work but only partially. For example the “skybox” color will change but edge settings do not.

How about uploading an example SKP file that shows the problem?

Sure no problem. Here’s an old abandoned file that’s experiencing the issue.

Truck.zip (235.0 KB)

This is what I see immediately on opening. Profiles are turned off so there’s no edges displayed on rounded things like the wheels where the edges have been softened.

How does this compare to what you are seeing?

This is what I see:

As you can see in the screenshot, profiles and edges are disabled. Even if I re enable them, apply the settings to the style or create a new style and set it as default as soon as I re open this file it will revert to what you see in the screenshot.

All of my files open like this no matter what I change.

Without edges and profiles I find it difficult to work on a mesh and it gets really tiresome re enabling them every time I open a file (which I do many times through out the day).

How are you applying the settings? Your screenshot shows that the style as been edited but not updated. Are you saving the file after updating the style? This file clearly has Edges enabled in the version you uploaded.

I’ve tried 3 methods:

  1. I open an existing file, edit the style, click the “update style with changes” button then save the file.

  2. I create a new file, create a new style, click the “update style with changes” button then save the file as a template and set it as default.

  3. I open an existing file or create a new one and select a pre existing style that has edges and profiles enabled and then save the file.

Where are you saving the file to? Is it possible you are saving a different copy of the file each time? It’s weird that the file I opened doesn’t show that the style has been modified without updating and it does show the edges but you don’t see that when you open it.

I’m just using the same default save (ctrl+s). It’s unlikely it’s saving a new file, the file metadata shows the last modified date changing and the default folders are empty.

I’m really confused. I tried to solve the issue a year ago by Googling but had no luck. Finally decided today to register here and ask for help.

I’m beginning to think there’s something wrong with my Sketchup installation.

If there’s anything wrong with the installation, it’s most likely due to it being used on an unsupported operating system. Unfortunately SketchUp 2013 is long out of support and so there’s not much you can do with it.

FWIW, newer versions of SketchUp do have an FBX export option. It’s probably time to bit the bullet and upgrade to SketchUp 2019 Pro.

Well the problem is it’s not like upgrading just means I need to re learn the program or something slightly inconvenient like that it’s that upgrading means I loose the ability to export my meshes into IMVU from Sketchup completely killing my ability earn virtual currency.

However, if 2019 has FBX support I might be able to get it work. IMVU does have some niche quirks with it’s cal3D implementation so I will have to do some testing before I completely switch over.

Thank you for all the help you’ve provided and spending as much time as you have, I really appreciate it.

1 Like

Virtual currency? What can you buy with it? Only virtual food, clothes, etc.?

Good luck.