Style Colour Setting Issue


#1

I have a scene that’s in Architectural design style, colour setting ‘all same’. When I save the drawing, the style colour setting changes to ‘by material’. If I copy the style with a new name - it does the same thing. How can I set the style to colour ‘all same’ and have it stay that way?
I wonder if this is some bug because it’s never happened to me before?


#2

Is that style applied to a scene or scenes? Did you update the scenes to use the Architectural Design style? Maybe you could share the SKP file so we can see exactly what you have set up.


#3

Thanks for your interest Dave. File attached - for example, in scene Genplan. I want to set style colours as ‘all same’, every time I save the colour goes to ‘by material’. In by material format some of the components loose their line colour.20170731 Style example.skp (522.7 KB)


#4

When I opened the SKP file, the style setting for the scene called GENPLAN is set to Architectural Design Style A with the Edge Color set to All same. Can you open the SKP file you uploaded, select that scene and then make a screen shot of the Edge edit settings?

FWIW, those components that don’t show the black edges when you set to By material are showing the color their edges are painted. You could remove the material from those edges if you want to.


#5

Hi Dave… When I open the file the edge colour is set to by material. If I edit the style and set the edge colour to all same - and save, or save as a new style… whenever I open or save the drawing, the edge style goes to by material. I just want to save a style so that the edge colour is all same. Thanks for the info on painting the edge colours.


#6

After you change the edge color to All same, are you clicking on the thumbnail in the upper left corner of the Styles window? If there are circular arrows over the thumbnail, that indicates you’ve modified the style but not updated it.

Another thing to try is purging the styles from the In Model collection and re-applying the default Architectural Design Style from the library.


#7

Just a thought from left-field… if you are definitely saving the changed Style and then the Model…
When you installed SketchUp did you do it ‘properly’ ?
If you did not, then all sorts of weird and subtle issues can arise…
A correct installation is:
Find the SketchUp installer exe file’s icon [probably in your Downloads folder ?]
Select the icon, right-click > context-menu > “Run as administrator”.
Doing any other way - even if you have admin powers - is incorrect.
If you have SketchUp installed you probably don’t need to uninstall/reinstall.
Try this, close all instances of SketchUp.
Do the ‘run as administrator’ as outlined above.
When prompted choose ‘Repair’…
Try SketchUp again… any improvement ??


#8

Hi Dave and Tig
I think I’ve solved this… 2017 has been on my computer for several months now and I never had an issue until a few days ago. The issue is that when I open or save the drawing, the style wants to change to edges by material and displays in that way - the icon in the style box even prompts me to save it… I tried replicating this in 2016 and it doesn’t happen. So I think Sketchup has developed a bug or something and needs to be reinstalled.
My quandary now is whether to reinstall, or wait until Sketchup 2018 is released … I use a lot of plugins and it takes a while to install them all.


#9

There should be no quandry. I expect TIG was correct in that you hadn’t installed SU2017 correctly from the beginning. Repair the installation by right clicking on the installer and selecting Run as administrator. You won’t have to reinstall extensions or plugins because those aren’t touched in a reinstallation or repair.


#10

As I explained in my previous post - you can run the installer and Reinstall and choose to Repair what you have.
It’s a simple thing that takes a few moments.
You hardly ever have to uninstall and reinstall etc…

Even if you were to uninstall a version of SketchUp, then your own plugins are NOT affected and remain in the User…/Plugins folder relating to that version…
Similarly a ‘Repair’ leaves your Plugins untouched.

BUT remember that you must install choosing the context-menu item = ‘Run as administrator’.
Otherwise miscellaneous flaky things can happen seemingly at random…


#11

Thank you both. I reinstalled as described. I still have the issue - please see the attached.
On opening, or after saving, edge colour is by material and the style icon is prompting to save the change.
The saved style has edge colour all same (black).


#12

Solved …
I found this post from last October: 'Styles edge colour reverting to ‘by material’ '
I loaded a plugin called ‘SketchuCAM’ last week. I disabled it and restarted - all back to normal.
Thanks to everyone for their suggestions.


#13

So you’re updating the style and updating the scene after the change?

It’s weird that when I opened your file, it was just fine with the edges set to All same.

What happens if you make the changes and then use File>Save as… and save it as a new SketchUp file with a new name?


#14

Did see your latest post. Glad you got it solved.


#15

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.