Edges colour problem

Hi everyone,
After years using my dynamic cabinets all of the sudden edges on some components changed colour.
How is it possible and how can i fix it_S1D.skp (2.7 MB)

Is it possible that you have edited the edges in styles to By Material rather than All Same.

that was it. but don’t remember doing it. thanks a million.

Dňa pi 1. 11. 2019, 12:55 Box via SketchUp Forum sketchup@discoursemail.com napísal(a):

I also see some faces bleeding through where different components meet or overlap. You’ve hidden the edges but not the faces. If you hide those faces, too, your model will look much cleaner.

yea I know. it 's there to show some cutouts in the side component when needed but the face is needed too that it look Like one face. it’s nested component. thanks @DaveR

Yes. I know they are nested components but if you can hide edges when you don’t need them, you can hide the faces. But it’s your component. You can do it however you wish.

I really appreciate any advice and suggestion. all I know to work with sketchup I have learned here on the forum from you people. thanks @DaveR

@Box would you know why the style edge colour doesn’t stay at “all the same” and keeps switching back to “by material” ? it is getting pretty annoying to set it to all the same every 15 minutes.

Have you update the style to save the changes?

yes I did . saved as template. than reopened sketchup from template and again by material.
the thing is I didn’t change it to color by material at first place. it just happened.

What if you upload your current file that does this? Maybe we could see it and tell you how to fix it.

I’m not seeing any issues with your component on my PC which suggests it is something on your system that is changing the style, it could be an extension.

ok @DaveR and @Box i have installed couple of them recently. Isolate selected layers, Sketchucam, Sketchdata reporter and that is it i think.
when i open the template (uploaded) , i always get to go styles, in model, and than click on style an than i updates the all same.modern interier.skp (1.6 MB) -template
here is also the template with a kitchen cabinet that edges get by colour style and than univetzal carcase that is ok (all same). -template wit cabinets-template test.skp (9.4 MB)

I’m not able to follow what you are trying to say. When I open your template file, it shows the style has been modified but not updated. The modification is that Edge color is set to show By Material. This would cause your edges to show light gray instead of black. Did you make that setting? Or did Sketchucam?


I don’t know what the “modern interier” file has to do with anything. All it contains is a low resolution image of Africa.

I also don’t understand what this means.

@DaveR excuse my English. I learned it in pub in Dublin couple of years ago. :blush:
the thing is that I did set the edge colour to all same and than set it exactly as you are saying. than I have saved the template under the name modern interier. the globe is a global component where I can set material for entire project that I work on. but that is not important…
when I open sketchup I go styles and the colour is set to by material , I choose all same , set it to style. than I see the edges all same but only for couple of minutes (like 15 minutes ) , than suddenly something happens that looks like the sketchup refreshes and than the style is suddenly back to colour by material.
I don’t do anything it just happens like this.
even when I set it to all same and save project as template when I open the saved template (where the settings should be set to all same) it is set by material again. it drives me crazy so I ask for advice .
hope you understand it better than before. :blush:

It looks to me as if you aren’t updating the style after making the changes to it. The circular arrows on the thumbnail indicate the style has been edited but not updated. Click on the thumbnail to update it.

that is what I did exactly. set all same and hit the the thumbnail to upload. than it is working for 15 minutes until the weird refresh of sketchup and I can do it all over again.
It seems like it is not updating the style at all after all.

What refresh? If you don’t save the changes at some point you’ll end up going back to the un-updated style. Update the style and hit Save immediately after.

OK it seems working now @DaveR . finaly it updated style and keeps all same but i had to uninstal the sketchucam.