In the Styles Box for Edge Settings, color changes from "All Same" to "By Material"

Current drawing fades as I try to draw a line or rectangle. Seen the Edge Settings for color changes from “All Same” to “By Material” - just installed the Flexpipe Creator Extension. Have uninstalled and
it does not change. I have reset the Styles back to Shaded with Textures and all looks good again until I start to draw. Is it a graphics savings feature that can be turned off? Help -Thank-You!

Show us a screen shot of what you are seeing and share the .skp file.

Are you still using SketchUp 2017 as your profile indicates?

Good Afternoon,

I am using SketchUp Pro 2021.

Below are pictures of the before and after effect. Unfortunately, these snapshots don’t show

to much. Maybe look at the file will help?

Thank-You!

Ken

image002.jpg

image001.jpg

Test drawing for DaveR 01 26 2021.skp (1.28 MB)

I’m not quite sure what the issue is. In your uploaded file you have a lot of rounded surfaces, profiles turned off and edge color set to By Material which means edges that have the light colored materials you’ve used on the faces will also appear light.

As received:

Turn Profiles on and set to 2 (I prefer profiles at 1.)

Profiles on and edge color set to All Same.

Generally while you are modeling I think it’s best to keep edge color set to All Same. Maybe, if you don’t want the edges to show so dark in your output, you might switch to By Material or maybe just turn off edges.

Note that with the Face Style set to Hidden Line and Profiles turned off the rounded stuff disappears. With the Edge color set to By Materials, those edges that have materials applied to them are displayed lighter.

The change happens by itself. All I am doing is trying to draw a line and it changes from
“All same” to “By Material”. Try it on the file I sent you after you change it back to “All same”
try drawing a simple line.

I’m not getting a change in the style when I draw a line or other shape. Here I’ve reverted to your original file and started drawing. One thing to note is that your style has been modified but not updated. This is indicated by the circular arrows on the style’s thumbnail.

And here it is after setting the style back to All Same. It stays set to All Same for me.

Good Morning Dave,

Try this before you draw a line, have your color set to “ All same” not Material then draw a line.

image001.jpg

image001.jpg

image004.jpg

I did that in my second GIF.

Hey Dave, what did you do to keep the color from changing to By Material because mine still changes even after I have modified my thumbnail in Styles?

I didn’t do anything to keep it from changing. It stayed as set. I’ve never had any style changes occur while I was modeling.

Maybe you could try repairing the SketchUp installation. Are you still using SU2017 Pro as indicated in your profile?

I am using SU2021 Pro, I don’t know how to change my Profile.

Click on the green circle with the K in it up in the right corner of the forum page. Then click the person icon immediately below. Then Preferences and Profile.

If you are going to try repairing the SketchUp installation, close SketchUp. Find the downloaded installer, right click on it and choose Run as administrator. Then Repair.

Thanks Dave, got the Profile updated. Will work with our Admin for repairing installation.

You’re welcome.

The installation should be done under your Windows user and the Run as administrator is not the same as having admin rights on your computer.

We (IT/IS) ran the repair as Admin and still have the same issue when drawing a line and color prompt changing to By material. I also did a reboot.

Maybe @colin has some idea. I’ve never seen the style change by itself.

Thanks Dave