Edge styles default to color "By Material" when my model auto-saves or saves

I’m running pro-18 and as I work and the model auto-saves or when I save the file manually the edge style defalts to “By Material” which much of the time makes things disappear (should be “All same”) such as imported DWG lines. Has anybody come across this and know how to fix it?


Can you share the .skp file so we can see what you’ve got?

Its a default setting of some sort, it happens on every model.

square.skp (99.7 KB)

So you’ve edited the style as indicated by the circular arrows on the large thumbnail. If you don’t want those changes, go back to the In Model styles and reselect the style. If you wanted to keep the changes you’ve made, click on the thumbnail to update it.

Yeah I thought that too but it doesn’t work. If I change color to “All same” and update style, then when it auto-saves or I save it, it goes back to “By material”.

The really weird thing is if I create a scene while I have it set to “all same” and update, after it auto-saves or saves, and I click the saved scene it will revert back to “All same”. Then when it auto-saves it goes back to “By material” again,no matter what. I’m having to click the scene every time it auto-saves while I work.

I’ll attach one with a scene.square too.skp (101.4 KB)

The file you uploaded this time has the edge color set to All the Same. You’re saying that when you open the file it opens for you with the color set to By Material?

Question: When you have a modified but not updated style and create or update a scene, do you get a warning message popping up asking what to do about the style?

Thats correct. When that file I uploaded auto-saves or saves it reverts back to “By material”

Weird. Does this one do the same thing?
square too dr.skp (102.2 KB)

Yes. Same result.

Interesting because the style has the edge color set to All same.

At this point I think I would start by repairing SketchUp making sure you right click on the installer and use Run as administrator.

Yes also a new model should start as "All same " too shouldn’t it? When I open a new file it starts as “By material”.

By repairing, do you mean re-installing it?

Depends on what the default style in your template.

Repairing it: Right click on the downloaded installer, choose Run as administrator, when the options are presented, choose Repair.

Ok Ill give it a try…

1 Like

Didn’t seem to work. I also went through a bunch of templates and they all start as “By material” as edge style.

I suppose if I re-install I’ll have to re-do all my extensions and such won’t I?

No. Extensions are installed in a directory that isn’t affected by the installation.

Can you open a new file and immediately save that to upload here?

new.skp (97.3 KB)

Ok this is only saved and uploaded

So apparently your default template contains a style that has been modified but not updated.
Screenshot - 2_20_2020 , 7_34_33 PM

What happens for you when you open this one?
Untitled.skp (10.3 KB)

Same result

So SketchUp is changing that setting when it opens a file. Weird.

Yeah its strange. It started happening about a month ago or so mid-way through a project.