Styles edge colour reverting to 'by material'

styles
materials
color
edges
edge

#1

Its driving me mad to the point of not wanting to use this software anymore quite frankly!

Been using it for MONTHS with absolutely no issue at all. Then all of a sudden ALL of the lines on my model turn either white, or a paler version of the main body colour (so a red panel suddenly gets pink lines).

Every single time I save anything, it reverts to this mode, and any time a model is inactive, it reverts to this mode.

I have to go into styles, to the edit tab and click the bottom box ‘Color : All the Same’ - because it KEEPS reverting to ‘By material’.

I havent done a single thing to make it decide to do this - no amount of clicking refresh, restarting, making new styles, clicking around or swearing solves the problem.

I just cannot understand why such a stupid feature exists and how to stop it happening. It becomes almost impossible to model anything when all the edges are suddenly impossible to define.

Please help!!

(the only thing I could think of was a bug in SketchUCam that I tried - I have deactivated this and the problem still exists!)


#2

How about sharing a SKP file that exhibits this issue?


#3

This one is prior to saving - exactly how I want it


#4

Whereas this is after saving / after a period of idle (autosave I presume, turned that off too as it seems to make it unstable and crashy quite a bit)


#5

I’ll ask again. Could you share the SKP file?


#6

ExampleFile.skp (1.2 MB)

Just made this, changed the colours and boom - its doing it.


#7

In Preferences>OpenGL, try turning off Hardware acceleration. Do you get a change in behavior? Also delete and purge the 3D Printer Build Volums component from the model.

I opened your file and had no problems.


#8

Can this be tied with wrongly assigned shortcuts?


#9

I don’t know if this setting can be accessed from shortcuts but this got me thinking that it is maybe a plugin behaving strangely. Are there any plugins installed that are supposed to modify styles in any way?


#10

I tried all of the suggestions on here - reset the shortcuts, closed Sketchup and re opened it and BOOM! back to normal.

I remember now that as well as installing a couple of new extensions, I also tried setting a keyboard extension for deleting guides and the protractor.

Weird one!

But solved - THANK YOU ALL!


#11

Glad it all worked out. :slight_smile: