Styles overriding themselves

What I have sometimes inadvertently done is to click in the Styles panel window that has the “modified” arrows showing. This updates the style.
I tried changing the settings by first turning the warning dialog off, and then selecting the “Update the selected style” but even that didn’t make style changes automatic.
image
@betazero , can you post a file that does this to you?

I had another thread about this and did tests. It was related to the profile thickness having anything other than 0. The latest version is a little better but still has about a 0.5-1 second pause after many commands.

It’s running from ssd internal hard drive iMac Pro

The skp is on Dropbox that’s on local unless it has something to do with that? I have never had problems like that before though.

Yes I reset warnings

Maybe I need to fully remove sketchup and all related files? I have done that before and can try again. I know there is stuff in application support etc. where is the warnings thing stored that keeps passing the setting along for each version?

Yes. 11.6

I would say this could be the problem and would like to eliminate it as a possibility but that would not explain it doing it after double clicking on a component. I have reset warnings but this box did not return. Is there another way to get it to show up so I can see what it is set to?

Thanks,
Russell

Yea sorry I saw that you said that and revised my reply to you. I had “ I run it on a Mac” ptsd. So many times I get people running pc trying to solve a problem on a Mac version.

And we so often have people wanting help without providing enough information, like the specific version of Mac or Windows they are using.

I get it, no big deal. How about some of my questions, could it be a permissions issue with your SketchUp install? Is the SketchUp app in the applications folder? is any part of your workflow involving the cloud? Do you have autosave enabled? I’m not on a track, just looking for options. You could just trash SketchUp and reinstall fresh from a downloaded disk image to be sure. You would need to reinstall your extensions but there are only three, right?

Yes the nls problem has been around for 6+ years. Export a dwg from Sketchup using a Mac then try to xref that Dwg into autocad. You will get around 6-8 nls warnings (once attached its once per update or when opening the main drawing it’s once per attached xref). The only way around it is to open the drawing and save. That becomes a pain when you have around 15 xrefs attached and constantly updating them. Sorry I am not a fan of layout and have automated autocad using Autolisp to a point that just does not leave layout as an option. Even with the Nls warning nuisance

With Mac most users are always just on the latest version. It’s not like windows where some people are still using windows 7.

I see your reply now. This could be a combination of autosave and dropbox conflicting. Is your working file loaded over the cloud from dropbox? Working on a file from the cloud is commonly known to cause conflicts and corrupt files. You say the file is local?

No they aren’t, so many options for mac depending on the age of the computer. Windows 7, 10 or 11 can be different, but Mac has a whole range of names and processors. Or you on an M1 for example?

I answered many above but I will put them here
Not sure about any permission issue.
Sketchup is in the application folder
All my files are in Dropbox but on local machine
Yes auto save is on
Yea I can try a full clean install and will tomorrow
I only have 3 extensions so not big deal ( wish shortcuts were cloud based…… )

Interesting, is Dropbox set to automatically keep files up to date? You might try turning that off and manually syncing at the end of each day. I have not used Dropbox for a while but we see many funky interactions here on the forum from files being synced to the cloud while autosave is running. Both systems trying to access the file as the same time.

1 Like

Yea the m1 thing I understand but unless your on a non compatible older ( like 2014 now I guess) Mac I think the majority of people are on the latest os version. I am running latest os including the update from today. iMac Pro 2017 soon to be studio Mac in like 10 days. My m1 laptop had the lag issue, they all have the nls issue but I don’t work all day on my laptop to see how many time the style problem pops up. I have seen it happen once while on vacation doing some emergency modeling back with the painful 2 second delay version of sketchup.

So, your profile is incorrect.

Oh havnt touched my profile in a while. No idea how you change that on a phone. Anyways it’s latest version of sketchup, os and yea I have an iMac Pro now with Vega 64 and 128 gigs of ram.

Exactly my point, many people even move to windows from mac and don’t change their profile information.
When I see, ‘the latest’ I see someone who doesn’t want to be bothered with updating their profile and as such it tells me not to trust anything in it.

I was going to respond “differently” to this and the other thing about my profile but it’s pointless. I had already said latest sketchup and mac os. The only thing missing would have been video card. Vega 64 but I don’t think that the drivers for my video card are overwriting styles randomly.

I use PC, and have never heard of this issue on the forums with many MAC users, but I can’t speak from experience with that platform. I simply find it odd that you are convinced it is a software glitch when only you are experiencing it. Now if there were multiple cases or even just another to confirm that would be one thing. But only having your experience logically points to process and not software.

I can tell you I used ACAD for over 20 years with heavy useage of .lsp processes and I am so much faster with LO…painfully faster! So while I’m sure I can’t convince you, you are leaving speed on the table with your process.

This is getting off topic. Yea sketchup is very different between pc and Mac. I just don’t want to keep having to turn my section cuts back on and saving my style. Yea been using autocad for 20+ years too and have tried to get layout to be a replacement but yea I don’t get how it could be as fast as or even close to what I have setup. Just dimensioning alone is such a pain in layout unless I am missing something….

Also, once you see that is not the same os you use ( especially for sketchup ) you should probably drop out of the topic. There are many things done completely differently in the Mac version.