Saved View 'Style' Changes When Clicking 'Scenes'

bug

#1

Hi, I find SU2017 to be very buggy but I have one problem in particular that affects me and now my clients who are using SketchUp to view the designs I send to them. I do remodeling design and always save each scene in ‘Shaded with Texture’ style so my clients can see what their homes will look like. Since I have started using 2017, when I navigate using Scenes, the Style changes to ‘Wire Frame’ and also the axis which I have turned off turns back on. I have never used Wireframe for my work so reverting to it seems strange.

This happens in some but not all models and now I’m hearing from my clients that they are seeing wireframe too. I’m not sure if they have the same bug on their computers or if my computer is including the bug in the files I send. I suspect that the latter is the case because the scene thumbnails are starting to show as Wireframe in my models too.

I use a brand new iMac (previous computer was iMac as well) and my clients most often use Windows. I never had an issue with previous versions of Sketchup and when I tried to revert to using 2016 on my new mac, the same thing happened so I went back to using 2017.

Is anyone else having this trouble? Are there any work arounds that you’ve heard of? It’s very frustrating to me but, much worse when I cannot serve my clients well.


#2

How about sharing a SKP file that shows this problem? Share it privately if you don’t want to make it public.


#3

Thank you for your interest Dave. I removed client info from this file and have no problem sharing it. The file was too big to upload directly but I think I have seen others share via Dropbox. Please let me know if this doesn’t work for you.


#4

Thanks for sharing the model. Sorting out the problem is dead easy with the model in front of me.

The problem stems from the fact that although you edited the style, you didn’t update it. The only In Model style you have is Wireframe. That’s what each scene will use. Note in my screen shot the circular arrows on the style thumbnail in the upper left of the Styles window. They indicate the style has been edited but not updated.

I’m going to guess that you have disabled the warning message for style changes when creating or updating scenes. Go to the SketchUp menu (left of File) and click on Preferences>General. Make sure there is a check in the box for “Warn of style changes when creating scenes” and when you create a new scene or update an existing one, use one of the first two options when that warning pops up. In the screen shot below, I updated a scene and got this message. In this case, I choose Update the selected style and click on Update Scene.

After doing that, the style shows as updated in the Styles window.

Since it’s the only style in your model, all the scenes show with the faces, textures, and shadows as you’d expect.


#5

Dave R.

I can’t thank you enough. I am always impressed with people that go out of their way to help other people.

I think I disabled the warning message for style changes back in SU2014 because it didn’t seem to make a difference. Perhaps with my new computer and operating system it finally did. I don’t know how 'wireframe got into the picture either since I never use it but your solution worked for me

Thanks again, Karma should be on your side.


#6

I’m glad that was helpful. I never thought about it before but maybe the status of the warning is a preference that gets carried over to the new version like shortcuts do. Recently there have been a few posts about scenes and styles that are caused by disabling that warning so you aren’t alone.

If Karma is with me, I hope she has warm socks!


#7

Karma’s socks are the warmest! unfortunately you never know when you will get them. You might want to go out and buy yourself some if you need them now.

It’s -7 degrees in Minneapolis this morning.


#8

Good point. It was warmer here in Rochester at -5°F but we’ll be wishing for that warmth on Thursday.