Sorry. We encountered a problem with your web browser's WebGL support


#1

Getting this message when trying to launch SketchUp for Schools on our faculty devices (Surface Pro 3). We are using Google Chrome 58.0.3029.110. Is there anything I can try to troubleshoot or are we simply out of luck on these devices?


Web browsers WebGL Problem SketchUp for schools account
Sorry. We encountered a problem
#2

@jschlackman-cesjds lets try a few different troubleshooting steps. Before starting I want to make sure that we are clear that we need to check a few browser settings. They may have been set by the school’s IT department so if one of these fixes the problem I would double-check with them to make sure it is ok by them also.

  1. Try going to the following site in Chrome: https://get.webgl.org/. This site will tell you if the browser currently supports WebGL. I am guessing this will tell you that it is not enabled but I want to double check.

  2. Check that the WebGL flag is turned on for the browser. To do this enter the following into the address bar and press enter: about:flags. You will be presented with a list of flags for your browser. Search for ‘WebGL 2.0’ and let me know what that setting is.

  3. Check that the shortcut to launch Chrome does not include any flags that could be disabling WebGL. To do this right-click the Chrome icon then go to properties. It should just show the path to the executable and not any other flags - meaning text starting with a single or double hyphen. If there are flags then let me know what those are.

  4. The last thing to check is that you are using Hardware acceleration when available. If this setting is turned off then the message you received will appear. To check, open Chrome Settings > Show Advanced Settings > System. There is a setting labeled “Use hardware acceleration when available” and that should be checked. You will need to restart the browser when toggling this setting.

Let me know what you find.

Thanks

Jon


#3

Thanks for your reply. Helpfully I am the Director of IT at the school, so no problem with getting permission to change anything…

  1. As you predicted, “While your browser seems to support WebGL, it is disabled or unavailable.”
  2. WebGL 2.0 is set to Default. I tried changing to to Enabled just in case, but no change.
  3. The shortcut does not have any flags.
  4. The “Use hardware acceleration when available” setting is checked.

#4

I think I’ve determined the issue, and wanted to let you know for reference.

When I’m at my desk, I connect a second monitor using a USB 3.0 dock which has a DisplayLink chipset. Apparently just having that second display connected when launching Chrome (even if Chrome is running on the built-in Surface display) is enough to hobble WebGL support.

What’s more odd is that if I start Chrome with the second display disconnected, and then connect the USB display, WebGL still works, even on the display connected via USB.


#5

Thanks for the response. We now need to figure out why WebGL is not working on the machine. The response from https://get.webgl.org/ tells us that it is possible but it is disabled for some reason. The fact that this is a Surface Pro should not be the reason this is not working. We have a few in the office and we are able to launch the site without issue.

I would try the following to troubleshoot the machine:

  1. Do other non-Chrome browsers access the site correctly? If they have the same issue then it further narrows it down to the machine.

  2. Are the graphics drivers updated?

  3. Do you have any Extensions installed? Try disabling them to see if any of them are messing with the WebGL settings.

  4. Lastly, open Chrome and go to: chrome://gpu/. This will tell you the status of the Graphic Features at the top and also a list of Problems Detected. I will not be able to help out with this step but it should provide a starting point to troubleshooting why WebGL is not working on the machine.

Jon


#6

Just saw your response, that is interesting. I do not have that setup locally so I won’t be able to reproduce. Let me know if you see anything that could help out other users.


#7

I had the same issue… just found this on another google forum and it solved the problem:

You need to enable hardware acceleration for WebGL.
Click menu icon and go to Settings.
Click Show advanced settings.
In System section, check Use hardware acceleration when available.
Restart Chrome.


#8

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.