Something went wrong trying to load folder

trimble connect not showing my models on sketchup web, and seems to think im brand new to the tool despite me using it for about 5 years now and having hundreds of models

1 Like

SketchUp Free hasn’t been available for five years, yet. Typically when users of the free web version can’t find their previous models it’s due to using the wrong email address during sign in.

well i’m autocomplete signed in and the account name and everything is right, it just says “something went wrong trying to load this folder” and has done so for about 3 hours

I also tried on my phone and with a brand new account with new email, all fail, i assume trimble is just down right now despite not reporting it on their website

it’s still down, website still says it’s fine but i still cannot access any of my models

What happens if you go to connect.trimble. com and sign in? Can you see your models?

When i try to sign in, it just loads forever

What browser are you using? Where on the planet are you?

When I sign into connect.trimble.com I get in within seconds.

You have two gmail addresses, one that includes ‘Luke’. The email address you use in the forum is the one that has been around for 4 years. Make sure to be signing in with that one. The ‘Luke’ one was only created today.

im in new england united states, i tried bing safari and google

yes using the luke one i created a new account to see if it would work or have the same issue

But as Colin indicates, you have two different e-mail address.

yes but linked to separate accounts as far as i know

I understand.

I don’t see any outages at all, and haven’t heard of other people with the same problem.

When you tested on your phone, was that still via the same network as your computer? Do you get any further if you use the phone as a hotspot for the computer?

Trimble Connect do have their own support contact form, it could be worth reporting the problem to them:

https://go.trimble.com/Connect-Support-Form.html

on my phone i was on wifi on my pc i am on ethernet but it is from same router

Could this be a firewall isue?

nope i don’t think so, turned off my firewall entirely and still had same issue

1 Like

essentially it seems my whole account is broken, signed in on different devices different networks different people tried it and it gives same error no matter what

I can’t think of any problem that your main account could get that would also affect the new account you tried.

This support page lets you send in the details of the problem without you needing to sign in:

https://help.sketchup.com/en/contact-support/billing-question/form

Or if you can sign in but don’t see your content when going to this page:

try the Trimble Connect support page:

https://go.trimble.com/Connect-Support-Form.html

is it worth mentioning that my mother created an account on a different pc with a vpn in the same household and had the same issue?