Solution: Sketchup Select Tool Slow

Hello Everybody, I just have encountered a problem all of a sudden with (after a window update may be) selection tool become too slow to select like 7s.
I researched many topic in the community but couldn’t find “my answer” to fix “my problem”.

This may or may not work for you but it fixed mine.
It turns out after a window update. My Default Graphic processor was set to “Integrated Graphic card” instead of “High Performance NVIDIA Processor” as preferred graphic processor.

To access this setting, Right Click on Desktop> NVIDIA Control Panel > Manage 3D Settings > Global Settings > Preferred graphic process (chose) High Performance NVIDIA Processor.

If it was originally set like this, then sry I couldn’t provide any other solution.
If not change it as mentioned about and restart Sketch-up
I took whole day finding solution I hope it helps you too. Good Luck.


This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.