SketchUp zoom extents issue with text


#1

I’ve got a model that zoomed right out when I tried to orbit, becoming invisible except for the text labels and unable to zoom in etc.
Searching through the other posts on here, it seems like it’s either a massive or far-away entity (I can’t find one) or a problem with a mis-pointed label. I think the second is very likely but I can’t identify it, I tried deleting them one by one but this changed nothing except I now can’t see anything!
Help please - it’s not at all a complicated model but there’s some info on it that I can’t remember to re-create it.
Sorry, I’m new to this so apologies if anything’s not clear.


Zoom Extents goes to (near) infinity
#2

If you upload your model using at the top of the reply window, I’ll take a look at and see if I can fix it. I’ve seen a bunch with symptoms like you describe and could usually save them.


#3

Draft Plan 9m.skp (150.7 KB)

Thanks slbaumgartner - much appreciated! I saw your name on the other posts I looked at - I’ll make sure to put my text in different layer next time!


#4

There were a bunch of Texts that were astronomically far from the origin. Whatever it is that triggers this bug in SU, you evidently hit it multiple times! Here’s what I was able to recover (the texts on Pluto are gone).

Draft Plan 9m - fix.skp (173.1 KB)


#5

Thanks - that’s brilliant! Wish I knew what it was that caused it - possibly deleting a face that had a label pointing to it?
Sorted this one anyway - much appreciated


#6

This is about the third time we’ve seen this bug identified on the forum. Has anyone submitted a bug report?

An excellent hypothesis.


#7

It is somehow related to having a model that is 2D and placing annotation texts around it, though so far nobody who’s had it happen can say exactly what provoked it, they just see the consequences later as you did.

Texts are a strange beast in SketchUp. The actual words are tied to the screen; they always face you and don’t scale with the rest of the model. But they also have a leader line that points to something on the model. So at one and the same time they are attached but not attached to the model’s geometry. I think there is a bug in how SketchUp calculates the positions for the leader, perhaps when the on-screen location of the Text in the current view isn’t atop any object in the model…


#8

I haven’t, largely because I haven’t found or heard of a reproducible action to trigger it. From having been in software development myself I know that bugs with no reproducible trigger are the hardest to track down and are often pushed aside in favor of more tractable ones.


#9

I’ve got another example. It also has label text placed on a 2D model. When incorporated as a component in a larger 3D model, that model too has the same weird behaviour.

If I turn off text visibility the model behaves normally with Zoom Extents, so it is clearly directly to do with the text.

This seems to be the same issue as reported above. Here’s the model in case that helps diagnose why it happens.
Int elev shafts columns and walls.skp (235.4 KB)

When I have the label text turned on, and Zoom Extents, the model geometry shrinks to a tiny dot in the middle of the screen - like this - and the text starts overlapping badly. Furthermore, the viewpoint changes drastically, inverting the blue axis.

And there’s lots more white space too between the text shown in the image, and the edges of the drawing window.

I’ve made crossing windows in the blank areas when the text is showing, and there is no detectable selection anywhere, so there’s no stray geometry accounting for it.

Except for the floor numbers running up the curved shafts, the text is all in the component showing a plan cross section of where the elevator shafts will be located.

That on its own does the same thing.
Elevator shafts extended N-S JWM corrected.skp (49.1 KB)

Tricky to recover from - either need to Zoom Previous several times, turn off the text (on a layer, or using ToggleTextAndDims plugin, then Zoom Extents again.

As above, I can’t reproduce it in a simpler drawing. I thought it might have had something to do with a label having been attached to a piece of geometry which was later deleted, but a simple example doing that behaves as normal.

I had also moved some of the geometry with labels attached, and also moved some of the content of the text labels by cutting and pasting text from one label to another existing one, and sometimes changing the text in new labels.

So it still isn’t reproducible, but boy is it annoying - i need to orbit and zoom around a lot in this large model, from top to bottom of the long thin shafts, and occasionally get lost or lose sight of the model. Normally, Zoom Extents is a good way of recovering quickly, but not in this case!

I have wondered if it is to do with using a text with a fixed point size, whose ‘extents’ are really a function of the screen size, and SU then attempting to scale the geometry to ‘fit’ but that doesn’t seem to make much sense either.

Seems definitely a bug to me, but extremely hard to diagnose if it isn’t reproducible, as Steve says above.


#10

This topic was automatically closed after 91 days. New replies are no longer allowed.


Sketchup zoom extends with text and 2d problem