Sketchup zoom extends with text and 2d problem

I am using sketchup pro 2018. I found another thread dealing with this issue, but it is closed.

I will link to that in the next window. I am having the same issue described in a number of threads.
I am working with a relatively simple model. It is cabinetry. I used 2d squares to map the floor space of the cabinets, and made into components. I used labels to identify them. I have also made many other components and some groups, and may have accidentally grouped the text into an instance that the shadow boxes are not in. At sometime I used Zoom extents tool, and It zoomed out astronomically far.
After reading other threads I was able to highlight and erase all but one of the text labels with leaders. I can not highlight the remaining one to find out if it will fix the zoom problem. I have tried model info/text/ highlight text leaders, and it does not highlight. I have found the group it is in, but even with that group opened it will not highlight. It does highlight with the group, but not on its own, with either model info, the pointer, or attempting to deselect the group after highlighting it, using the screen or the outliner box.
I am re-starting this thread for:

  1. please help me get my model back in working order
  2. My instance is matching several others where text and a 2d object in a 3d model are contributing to this zoom extends glitch. In all cases it seems loose text is causing the problem, and many complain of this 2d source as part of the problem

intel core i5 7th gen, hd620 on board graphics, windows 10 SUpro 2018

Kitchen 1.0.skp (218.0 KB)

Kitchen fixed.skp (293.9 KB)

1 Like

Thank you DaveR Can I ask how you fixed this. Now that it was zoomed in I can see the the text was actually accidentally included in a component nested in the group. I will be more careful with text prior to creating scenes towards the end, but I am sure something similar will happen in the future.

These Ruby snippets can be used to identify and purge invalid text.

1 Like

The way I fixed it was to copy the geometry in the model and paste it into a new one. Before copying it, though, I delete a gazillion guidelines.

Thanks. For some reason that did not work for me when I tried it. I had not deleted the guidelines. I don’t generally keep that many around, but in this situation they were needed. I was creating the “shawdow” boxes so I could get rid of the guide lines when I encountered the problem. Thanks for the help.

The problem is a text object “Pantry” that had errors in its position. I moved it back to the origin. I didn’t delete any guide lines. The guide lines weren’t causing any problems, they’re always infinite anyway so would’t affect zoom extents.

pantry
Point: ( --2147483648", --2147483648", --2147483648")
Vector: (nan, nan, nan)

nan is not a number.

Kitchen 1.0.1.skp (270.3 KB)

1 Like

Thanks McGordon. It seems this text problem is becoming more frequent, or more noticed. Several entities have now published work arounds, and code solutions to the situation. Now that I am aware of what was actually causing the issue I should be able to fix on my own, and draw in a way to help mitigate it. As to what is creating the issue, it seems to be becoming a known bug, and hopefully a true solution will happen soon.
One thing that was curious to me was that the text would not highlight for me when using Model info/text/highlight leader text. Or Model info/text/highlight screen text. Even though it showed with a leader, I guess it was not connected to an object and not defined as leader text, but also not defined as screen text.
Pantry was attached to the face of the 2d rectangle below when I started. It accidentally got selected and made into a component with the cabinet, and then nested in a group called wall 2 kiks. Somewhere after this it got detached and thrown out into space and the next time I used the zoom extents tool I was zoomed out into the T.A.R.D.I.S. somehow. I am including this in the hopes it helps others to figure out how this text separation issue is happening. I generally don’t add text to images until I am creating scenes.

I’ve written a Ruby script to find and if possible correct these problems with text. I couldn’t see the text on screen until the script put it back to the origin. I’m not sure exactly how to create the problem in the first place though.

The examples I have seen and helped fix have three things in common:

  • They have leader text attached to 2D surfaces (I don’t know that it can’t happen when 3D objects are involved, but haven’t seen a sample yet in which this was true).
  • The model has been edited after the text was added, and somehow the editing caused SketchUp to lose track of where the leader was supposed to go.
  • Later on a zoom operation attempts to include the “lost” text and this causes the view’s camera to move off to the outer universe.

Having identified the culprit, several of us have manual technique and/or Ruby snippets that can find and fix the issue. But nobody has yet found a reproducible example to show the steps leading up to the explosion.

1 Like

I will also add that I used Hide on components after the text got included in the group-nested component. This was shortly before I used the zoom extent and was shunned to the edge of the universe. I may suggest a name for this glitch after Douglas Adams and The Restaurant at the End of the Universe: The Milliways effect. :grin:

1 Like

+42!

I do so :heart: any HHGTG reference!

2 Likes

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.