Lost Model! A lot of work will be lost... HELP

Im using SketchUp Make 2017 on MAC. in I was working In the model and I clicked something and It looks like my model view is astronomically far away. It still shows my model entities so the model is there but Ive tried everything. Please help!

Widmer Dream House.skp (476.9 KB)

here it is in saved view. If you use zoom extents it takes you to the outer cosmos, maybe there is some rogue geometry out there that needs deleting.

Widmer Dream House2.skp (516.3 KB)

Could you possibly save this down to this version of sketchup? 17.3.116.

Is there an easy way to find this rogue geometry and delete it?

This is it in 2016 (the last was 2017 - that’s as specific as I could get). at least with scene 1 you can use it until it can be diagnosed.

I cant find the element, maybe its not that? someone else might have an idea as to what is happening here.

Widmer Dream House2 2016.skp (488.6 KB)

Thank you for your help!

OK, glad you have a temporary solution.
I tried making it a component and importing to new file - same issue
tried copy paste - same issue
tried selecting your core model and then shift selecting to inverse and delete same issue.

One interesting thing is that if you put the model into wireframe mode - then zoom extents works as expected.
So maybe its a face somewhere? but I cant find it.

1 Like

Model Info indicates there are two Text in the model.
But there are no text visible in the model space.

It’s the Detached Text Bug causing Zoom Extents to place the camera in outer space.


Running your Ruby snippet in @nickwid’s model has no effect.

However, there are 73 Groups in the model and no Components.
My guess is the Text is inside one of the Groups.
When I explode all the Groups and then run the snippet, it works.

It seems the snippet only works in the current context.
Is there a way to have it loop through the entire model?


@Geo is correct: you have two stray text objects (“UP” and “DOWN”) and they are nested inside a group. Here’s a repaired version of your model with these removed.

Widmer Dream House2 2016 fixed.skp (512.3 KB)

1 Like

After exploding all Groups these were exposed.

[#<Deleted Entity:0x22751da8>, #<Deleted Entity:0x227519e8>]

The snippet is indeed just for the active drawing context. It would be quite simple though to iterate the model DefinitionList and affect all contexts Another improvement would be to try to reset the text position to (local) origin, rather than deleting, so users can still read the text and manually place it anew where it was intended to be.

I haven’t the time myself at the moment but someone could make a plugin for this.


Would be nice if the text bug was fixed so nobody needed to make a fix.


My unpublished Ruby utilities do both, but would need to be wrapped as a plug-in. As @Box wrote, it would be better if the bug gets fixed! Fingers crossed for 2019.

Or Maintenance Release for SketchUp Pro 2018. It looks like the Web-versions are getting all the attention, so it could be tested there?


It could happen.
But the probability of a Maintenance Release this late in the annual release cycle is … ?


As @whiterabbitdesigncompany noted, the zoom extends does not causes the camera to ‘meteorize’ when Wireframestyle is active, so are the labels still attached to a face or…

Until fixed in SU 2019, I think the onus is on Trimble to provide a fixit plugin at Extension Warehouse.
@ChrisFullmer, can you help?

Here’s another victim of Text in Outer Space.

Hello folks,

I also ran into this “Zoom Extents Bug” after adding text to one of my models. NB: I have SketchUp Pro 2018 Mac version btw.

I just wonder if people who are using SU 2019 still have this issue?

Another post on the topic: I've also bumped into the Zoom Extents Bug

One way around the distant objects problem is to zoom out enough to see everything you want to keep, select those things and do a Cut, Select All, Delete, Paste in Place. That should fix zoom extents, but it leaves you wondering what the distant objects were.

In the 2019.2 update there is an Invert Selection option. You could select what you want to keep, invert selection, then look at the Outliner panel to see how many things are highlighted. Select one at a time, Cut, Paste while zoomed closer to the origin, and you should see the offending item.

In older versions you could still do a Select All, shift-select (to deselect them) the things you want to keep, and the offending items will be selected in the Outliner panel.

Thanks @colin,

I just did a zoomed selection of everything in my model, of what I was eager to keep, + did a fast copy paste of it all into a fresh new SketchUp file. It solved my zoom extent issue right away. I had no text bug in my model after all.

Problemo solved! :sunglasses: