My Sketchup model is zoomed out, and stuck, billions of feet away from the model

Here is the situation:
I am creating a 2d floorplan. Its a pretty small file… I haven’t been doing anything except for drawing 2d lines and boxes and such.

Somehow my model got zoomed out billions of feet away from the model. I cant find the axis. No zoom extents does not work. Purging unused didn’t work. Utilities didn’t help me find any coordinates so I can zoom back in. I cant draw anything because it is literally billions of feet to oblivion. Top view doesn’t work, Ive literally tried everything. The only chat forums I can find on this topic are people who has fixed the models for someone else without explaining how to do it and Im literally losing my mind. I need help asap, this is for a client and Im growing increasingly frustrated by the minute. Im not new to Sketchup but I literally have no idea how something like this could have possibly happened, its a very small file.

We cannot do anything until you attach the .skp file to this forum thread.

1 Like

Uploading now! Give me 90 more seconds.

You need to allow access to that file.

I thought I did, but just changed the settings. Let me know if that works

Did that work?

It is accessible.

I haven’t got the tools right now to get rid of them but the model has 250432 “text” entities that are probably somewhere in outer space as they have lost the entities that they have been attached to.

Yep! haha that is the problem.

The file is a mess. I’m working on it but it’s incredibly sluggish.

Removed all of the text entities, fixed the incorrect tag usage, and purged unused stuff from the file. File size reduced by almost 87%.
Screenshot - 12_30_2022 , 2_47_39 PM

Screenshot - 12_30_2022 , 2_56_03 PM

Screenshot - 12_30_2022 , 3_06_24 PM

Rogers Residence 12.29 fixed.skp (7.5 MB)

1 Like

Thank you! I have no idea how this happened though. My model is so small and 2d. how did you get rid of the extra ■■■■?

There was a lot of unused stuff in there. The file behaved so poorly before I cleaned it up that I didn’t go looking for the stuff. Probably stuff from the 3D Warehouse that you had imported and deleted.

After fixing the incorrect tag usage with an extension, and fixing the camera with another extension, I purged unused stuff and presto!.

Thank you so much!!!

1 Like

Just to add some usefull tools to the topic:

  • Camera > Zoom Extents - (Ctrl + Shift + E):
    Position the camera so all objects is shown inside of viewport.

  • View > Hidden Geometry:
    Allows to see hidden objects.

  • Also make sure all layers/tags are set to visible.

(Its not a fix method, it shows a picture of whats going on with the 3d model space.)