Zoom Extents goes to (near) infinity

zoom

#1

When I use Zoom Extent my model zooms out to near infinity and my huge model - over 800’ X 250’ shrinks to just a dot in the middle, except for a single label. What is causing this and how do I fix it?


#3

You have some rogue geometry somewhere at a distance from your model.
Go ctrl a, to select all, then hold shift down as you select only the part of the model that you want using the select from left to right, this should deselect the part you want, then hit delete, this should delete any extraneous geometry.
If that doesn’t work let us know as there are a couple of other options.


#4

There isn’t any rogue geometry.

It’s the text itself. Turn off the display of text and it will work normally.

I’ve just posted about the same issue - it seems to be a known bug, but the cause is not known and it isn’t known how to reproduce it for testing.

See SketchUp zoom extents issue with text


#5

No, this didn’t work. It took this long because apparently, one has to turn all layers on in order to be able to select them all first. And my 170MB model is very sluggish with all layers turned on. But after doing select all than surrounding what I want and then hitting delete it still zooms all the way out to near infinity.
Whatever rogue geometry is out there looks like it got captured as well.
What else can I do?


#6

Try turning off the text, using the ToggleTextAndDims plugin.

Or use Zoom Previous several times to get back to a previous view.


#7

Where do I find Zoom Previous?
And my model is now zoomed out so far I can’t do much of anything. I turned off all the text I could in layers, but apparently, I had a recent text in layer 0 so that one is still there.
It looks like I may have to go back to an earlier model before this problem and lose a day or more of work. Grrr…


#8

If you haven’t already, turn on the Large toolset and Zoom Previous is on it.

Or get it from the menu: Camera/Previous


#9

I tried camera previous about 50 times and although it makes the central axis jump around some, it doesn’t zoom back in.


#10

Ah, I did find one thing that worked to zoom back in. The styles menu general tab gets me back to the overall model.
But this doesn’t solve the larger problem. How can I get rid of the rogue geometry that is causing zoom extent to zoom out to near infinity?


#11

It probably isn’t rogue geometry. It’s the text gone rogue. Turn off all the text while modelling.

It happens just with the corrected Elevator Island plan component as I found out the hard way, like you.

Install the ToggleTextAndDims plugin and use it to turn off all text, and the model should then behave properly with Zoom Extents.


#12

One important lesson to learn from this: have at least one scene saved with camera location close to your model.


#13

I’ve repaired several models for people who encountered similar issues. Assuming the problem is from rogue text, not from other stray geometry, this is the first example I have heard about involving full 3D geometry versus 2D embedded in the SketchUp 3D model space. And, as @john_mcclenahan observed, so far nobody has caught the action that triggers the bug, they just stumble upon the consequences later.

The specific flaw is that the position and vector data for the text’s leader become corrupted, taking impossibly large values (often the magic “not-a-number”, aka “NaN”). Zoom-extents then takes the view’s camera to the outer reaches of the galaxy in an effort to display that impossible leader. Hiding the text dodges the problem because then the camera doesn’t need to be positioned to see the leader - but it leaves the flaw in place, waiting for the next time you zoom when text is visible. Using the GUI it is extremely difficult to select such rogue text to attempt to delete it.


#14

I managed to isolate the problem to specific examples of texts. Better yet, some of these examples came in from a much simpler model with text that I can actually upload here. It is only 42k. When you load the model, it’ll be zoomed to normal size, filling the screen comfortably. When you Zoom Extent, the model will shrink to a pinpoint, but the text, relative to the rest of the model, will zoom up enormously, though staying the same size on the screen itself.
There seems to be some sort of disconnect between model components and their sizes and text sizes. I wasn’t able to find the essential difference in anything having to do with font settings or anything else; I have text set at 14dpi, Normal, that works fine, and text set that way that causes the Zoom to near infinity problem. I can’t see any difference so I am uploading the model here in the hopes the community can diagnose the problem better.

For now, I will refrain from using this sub-model in my larger overall model…and then start to recapture what I lost in yesterday’s catastrophic zoom, about half a day’s work because I didn’t realize the problem until it was too late and then I couldn’t figure out how to get back. Now I know I can use a scene we had already built to zoom back to normal, but the problem with that is it turns on all my layers, which in a model with 7m faces, results in horrendously slow speed. I normally work with most layers turned off.

Elevator shafts extended N-S JWM correctedv2.skp (44.0 KB)


#15

SketchUp’s Text objects are special and peculiar beasts. Their position is determined by a reference point and a vector offset from that point. But the text itself is always displayed where that position projects onto the view’s image plane (screen) and is always oriented on the screen. It does not scale or re-orient as you zoom or orbit the model.

I’ll fix your sample model if you’d like.


#16

Yes, please fix if you can, and let me (us) know if there’s any way to prevent or detect this in the future. Thank you.


#17

Here is the repaired file. The text saying “0-4 then express to 91 then…” was the culprit. As noted, we don’t yet know what triggers this bug, so can’t advise as to how to prevent it. Since this seems to be happening fairly frequently, I am pondering writing a Tool to help a user repair the damage (my current methods require some sophistication and Ruby knowledge that would need to be made “user friendly”).

Elevator shafts extended N-S JWM correctedv2.skp (54.7 KB)

By the way, this model is indeed 2D embedded in SketchUp’s space, so it fits the pattern I’ve seen earlier!


#18

In the old model Scott uploaded (which I drew for him originally) I tried deleting the problem text, and re saving, then Zoom Extents. The problem was still there.

Even after Purging the file (Window: ModelInfo: Statistics : Purge unused) to get rid of the rogue text the problem didn’t go away!


#19

I think you mean Scene tab not Styles tab, don’t you?


#20

Ah much better!
Hmm, it seem this is a complex problem to solve, but SU ought to either fix it or at the very least provide a user-friendly work-around, as you suggest.

John - I saved it to the dropbox. Let’s use this one for now.


#21

Indeed. I’d already downloaded it from Steve’s post above! But we need to keep it in Dropbox.