Sketchup thinks my model is broken after scaling down


#1

Ello all. attached is the file that i am having trouble with. I made it in meters, to avoid small faces, then used tape tool to shrink it down to what my requirements are. However, when it was in meters, it would save just fine with no errors, now after i shrunk it down, it says its broken and i cant see where or how to find where it is broken:

scrool saw plate.skp (171.2 KB)

thanks for lookin and helpin. FYI, the diameter of the largest circle is exactly 3.1410 inches


#2

Hello,

Scaling it down will make you get an error saying your model has to be fixed, however if you do it the top face will disappear.

If you group it before you scale it down with tape tool, you will still get the error but nothing will disappear after fixing it.


#3

I shrunk it using the tape measure tool to 3.141 inches. That worked fine. But when I made it into a group, Solid Tools reported nested instances, which it couldn’t fix. If you do the same thing on the larger model, Solid Tools reports stray edges but fixes them. It does seem odd, I agree.


#4

UPDATE

Although Solid Tools reported nesting, it didn’t show up on Outliner. So I exploded the group and regrouped and the problem disappeared. I attach the final result.

scrool saw plate.skp (176.3 KB)


#5

This is the first I’ve heard of someone trying to use the tape measure advanced feature (scaling the model) for this purpose instead of the scale tool.

I would have started by modeling the circle at desired size, making it a component, then do the rest of my modeling within a scaled up copy of the component using the Dave Method.


#6

Thanks all for the advice and help. I will be looking at all the repliea soon. Im teaching chem and mayh at the moment and using my phone.

Whilst my student is doing his bookwork,poor kid, i have tried scale tool but i didnt like it haha. I found making it the size i wanted in meters than using tape measure tool to scale it down has worked great, except for this one model.


#7

I have some free time now.

Did you explode and then regroup after you shrunk it down or before?

I can not export as STL because of the errors. it throws a fit haha, hence why i am trying to fix it


#8

Ok, after grouping, then scaling down, i get no error when saving. I then un-grouped and it saved again with no error. This is odd.


#9

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.