Object scaling question in Sketchup Pro 22

I created a model using meters as the units, and drew a 100x100x100 meter cube. I then changed the model units to mm, and scaled my cube by .001. I expected a 100x100x100mm cube would remain, but when I used the tape measure it said I had a 98x98x98mm cube.

Can someone explain this? I am using round numbers and scaling this way should not cause roundoff errors unless I am missing something obvious. I am trying to avoid the dreaded small geometry when printing tiny objects and would like to avoid scaling objects up and down again individually. I know that STL files are unitless, but I would like my model to in mm when I open it. Just an OCD thing.

To what do you have Display Precision set?

I’m unable to duplicate what you described.

SketchUp Pro? Your profile says you are using SketchUp Free (web).

Are you referring to my community profile? I was using Sketchup Go when I originally signed up for the community, but upgraded to Pro. I have two separate Sketchup profiles that show up when I log in to the app, one for Sketchup Web and the other for Sketchup Pro, but I have no idea how I did that. I’ve attached a screen capture of my units setup. Thanks!

OK, I figured out how to change my profile here on the community to have the right version of Pro and my graphics card. Sorry for being a bit thick, trying to learn too many new things at the same times these days.

One thing I see in your screenshot is that you have Length Snapping enabled. This can create the issue you report. General advice is to turn that off.

Id be curious to see the model, can’t imagine what you have done to get that error.

By the way, OCD or not it’s not the best option to scale down to mm. Very small stuff can still fail when you scale down and try to export. Far better to model in metres and export the .stl to suit.

1 Like

It’s also worth noting that if you want to scale something to a specific size you can do so by using the units. The scale tool defaults to a percentage but using units tells it to use them instead. So grabbing a corner handle to start the move and typing 100mm,100mm,100mm and hit return will give you just that.

2 Likes

Hello, Box! So I’ve been playing and while I’m not sure what I did I suspect it has something to do with the scale tool. I select a top corner and apply a multiplier of .001 and this time got 90mm instead of 98. I think your note of using units instead of a percentage is the answer. I also learned by watching videos on YouTube that I can scale with the tape measure too. That said, it should not be that easy to get a malformed cube when trying to scale it down by 0.001x.

Thanks for the info on using meters, I will update my default template to do that. Hopefully one day there will be a workaround that does that automatically.

Thanks for your time! I really appreciate your help. I’m looking forward to the days when I will be asking more interesting questions. :smile:

Thanks, DaveR, I’ll keep in mind that Length Snapping can cause some issues. I appreciate the help!

I certainly can’t manage it. So unless we see the model or you record yourself doing it we will never be able to help you resolve it.

By now it’s probably too late, but if the model is still open and you can undo the scaling, I’d be curious to know what exact dimensions the cube had before.

Also couldn’t reproduce the problem here, Butt would the ‘Tape Measure Tool’ do the trick?
Go inside you group/component, measure one side and type the correct value, hit enter, click yes, see the magic happen :wink: