Scaling issues. Meters to MM

I created a spheroid using followme tool and embedded text into it and flattened its bottom and checked it for holes and saved it as a file. Reopened and it was fine. Then rescaled it from meters down to millimeters. Checked again for holes and showed issues. Tried to save and deleted top portion with text in it eliminating the surfaces. The issue seems to be the scale. Everything was pristine at larger scale, but got super buggy on small scale. Even when it is in millimeters initially. The text is in vectors so it doesn’t seem like anything should create an issue. Is this a common issue?

The issue is not specifically the Scale tool but that fact that by scaling the model down from meters to millimeters, you’ve created a bunch of very short edges and Sketchup tried t repair the model. What is your goal for the model? 3D printing? If so, will your slicer allow you to set the import units for .stl? If so, leave the model at meters and export the s.tl as meters. Then import into the slicer as millimeters.

Here’s an example. In this case I modeled in meters but imported into the slicer using inches.

As @DaveR implied but did not explicitly say, .stl has no capability to convey the units of a model’s data values. They are stored as mere numbers that require interpretation. The slicer must either assume or be told what units it should use. So, you can model at a large size in SketchUp, such as meters, and tell the slicer to interpret them as something else.

Why would the size of the lines/edges matter? It isn’t real world objects. Just numbers in a program shifting the decimal point. The manifold nature of it shouldn’t change? My goal is to 3D print it yes, but the .stl file definitely holds on to the size it is designed in. If it is in miles it won’t fit the print shape. In centimeters it could.

It matters in SketchUp because SketchUp has a built-in tolerance about small values to cope with the effects of computer arithmetic. During operations that create new geometry, SketchUp will delete edges shorter than about 0.001 inch and consequently any faces defined by those faces. This causes holes in the surfaces making up a solid. Scaling down does not add new geometry, so short edges created by scaling are preserved even when drawing them originally at that size would lead to losing them.

Just to add to @slbaumgartner 's explanation, with certain very fine geometry even scaling down to the correct size before export can show issues when 3d printing. Much better to work out what your printer sees.
Export 3 1m cubes and change the export properties for each, to m, cm, mm and see which is the right size in your printer software.

So you’re saying never create anything in millimeters even though it is offered as an option? It just can’t handle them? If so, what minimum units should I use and just rescale in 3D printer work space instead?

It’s not that you can’t work in mm it’s just that if you make complex shapes in mm you will be creating geometry that is smaller than the tolerance built into sketchup.
The program was originally designed for the architectural industry, long before 3d printing became such a common option, so very small and also very large things cause issues. General day to day measurements work correctly.

So to get around the tiny face issue you can use what has become known as The Dave Method (there are example of tiny failures in the thread.), or by working at a larger scale and simply exporting it so that is seen correctly in your printing software.
Generally for small stuff it is easiest to use m as if they were mm. No issues with trying to work out multiples of anything, just use 1m as 1mm and away you go.

That’s what folks here are saying, that by definition an .stl file does not hold any size information. If you could design a part that is 5 miles by 7 miles in SketchUp with the units set to miles, the, .stl file exported just says 5x7 without units. You could design 5x7 inches or 5x7 mm and the .stl would still only retain the integers 5x7. It’s the slicer (the program that reads the .stl) that determines what units are used when the file is imported, this is usually something the user can choose.

The .stl only records how many of whatever unit you have your model set to in the export options are used. Indeed, modeling with the model space unit set to meters and setting the import to mm is pretty standard, I don’t even think about it any more. You could model in miles and set the importer to inches, but the conversions are a lot harder to do in your head. :smiley:

Are you sure? I am pretty sure I have exported from Sketchup in larger units and smaller units with the same numbers and what appeared on the virtual print bed was different size depending on the file.

Why hasn’t Sketchup updated for larger and smaller values? The math can’t be that complex? My models aren’t like photometric extracts. Most are start to finish in Sketchup. Is meters the safe unit to use? What is the higher limit before it gets buggy again?

That .stl files have no units I am confident. But what you describe seeing when changing output units is also correct. Setting the output units in the .stl exporter will change the size of the imported file because the export unit determines the integers that gets recorded in mapping the .stl. For a simplified example, let’s say you designed something 1 meter by 2 meters in SketchUp. If you set the units at export to meters you get a .stl file that measures 1x2 generic units. If you export the same file with the units set to cm you will get an .stl file that measures 100x200 generic units. If you set the export to inches on the same file your resulting .stl will measure 39.3701 x 78.7402 generic units. This is why there is a unit dialogue in the export options, unless it is set to the same units that you modeled in the export will have different dimension numbers. Now consider those three files above, if you left the import units in your slicer set to mm and imported each one, they would all be very different sizes, the first would be 1mm x 2mm, the next a hundred times bigger and the third would be 39.3701 mm x 78.7402 mm.

The answer has to do with the programming of CAD measurement and floating point precision which I will not pretend to understand but I gather it is very complex and either impossible or at least not easily changed.

Yes, but success in 3d printing with .stl requires two settings be correct. Model in meters (knowing they will be mm) and set the output units to meters. Set the imput unit on your slicer to mm. So you make a shape that is 1m x 2m, export a .stl that is 1 x 2 generic units and import a shape that is 1mm x 2mm

I does not quite work that way as there is not an upper limit to edges or a size at which big faces fail to form. But there is a general upper limit for other reasons, as geometry gets far away from the origin things get wonkey and as the total model gets very large you will start to experience camera clipping which makes it hard to work on small things in a big file. Hard to say but I would place the maximum at around a mile, but this is a grey area answer, bigger models are possible if rules are obeyed, and you can have problems with models under a mile as well.

If I may add to @endlessfix’s notes: If there is an option to " set scale automatically " ensure the box is ticked.

You seem to know better. They are your models so do what you want. We’ve given you lots of information about how to work with SketchUp to create tiny details. I showed you an example which you seem to have ignored.

As I told you in my first reply, you would need to set the import units in the 3D printer software when you import the .stl file.

When I make models I design them using the units I want for the final printed object. I don’t change any settings when exporting as .dae file which then I convert to .stl with meshlab. I do not change any settings when importing into my 3D printer software. It just is what I selected before I started drawing.

Why all the trouble converting dae, export directly as stl.

1 Like

Sketchup doesn’t list .stl as an export option.

Your profile says ‘Latest’. The latest being 2021 does export stl.
The earlier versions like 2017 Make (the last version called Make which you also say you are using) needs an extension from the EWarehouse to export stl.
Even the web version exports stl.
Correct profile information helps us help you.

2 Likes

Yes I use the 2017 version because I don’t want to deal with connection issues. I assume this version is the last stand alone version?

SketchUp Make 2017 is the latest (last) no-cost version of SketchUp for the desktop. It is licensed for non-commercial use only.