3D print out is way too small

I have a drawing I did on sketchup web (free)
Its dimensions are 4.5"x5"x1.6".
When it is printed out, it is like fingernail small.
Increasing the size x1000 results in a width of 4" instead of 4.5".
Is there something I need to do for this?

What units is the slicer software set for? Millimeters by any chance?

Yes it is millimeters but it was set at 100% first.
Then it was set at 124.5. Only little bigger.
Then it was set for 1024.5. this put 4.5" at 5"
Then it was set for 1000. this put 4.5" at 4". ??

Does my drawing need to be converted to millimeters?

I’m assuming you exported from SketchUp as an stl file to send to your printer’s slicer? stl files are unitless, so what you see in the slicer will depend entirely on how you tell it to interpret the values in the file. If you drew in inches, the numbers in the file will correspond to inches but the stl file won’t know that. It will just have 4.5, 5, and 1.6 unitless. If you tell the slicer to treat them as mm, yes the object will be quite small. Changing to mm in SketchUp won’t help unless you calculate the equivalent of each dimension in mm from inches before drawing because, for example, if you draw something 4.5mm it will still be represented as 4.5 in the unitless stl file.

I can’t guess how you arrived at the scale factors you list, nor why they produce the values you give. The scale factor from inches to mm is 25.4 (not 24.5 btw), or 2540%.

Could you upload the skp and stl files here so someone can see exactly what you’ve got going on?

1 Like

I hear you saying I need to start over with the measurement settings set to mm.
However, I am not understanding why i can’t change this for the current drawing in the model info - length units from inches to mm.
When I do that the measurement for the length of my sample object changes from 4.5" to 114.3 mm.
Are you telling me the stl file doesn’t keep track of these units for the printer to see?
and 24.5 was a typo or memory lapse, what have you. I meant 25.4.
Not seeing where to upload the stl to this post. I did this once before but not seeing an “attach” anywhere now.

Easiest way to solve the problem.

sample (2).stl (1.4 KB)

Ok, found upload. It used to be in inches , I changed it to mm. Haven’t tried to print out again since I did that.

How about uploading the SKP file, too?

What is a skp? I exported it to an stl. I thought that is all that was needed.

The SKP file is the SketchUp file. If you saved it, there’s an SKP file.

Ok saw this on download link. Didn’t see that beforesample.skp (297.8 KB)

Can you just give me one know dimension.

“the length of my sample object changes from 4.5” to 114.3 mm"

What is the long dimension meant to be in inches?

114.3 mm is 4.5 inches. Your model isn’t changing size when you change the units.

You reverse to fix the blue back face. Right click on it and choose Reverse Faces.

It should be white faces out all the way around.


That is the size it is supposed to be. the length is 114.3 mm or 4.5 inches. I don’t want to change the size. Why is it printing out smaller than this?
What is a reverse face? Why does it need to be reversed? It printed fine this way. Or is that just aesthetic formality?

This is a common misunderstanding about what the units setting means in SketchUp. It governs the units that a user employs for input and the units that are displayed in the UI. Internally, SketchUp always captures values in inches, converting to and from the user display units as needed. I am on my phone, not computer right now, so I can’t check what the stl exporter does with regard to user units, that is, if you set mm does it export values as mm or as inches. In neither case will the stl contain anything telling which was done.

I’m not understandingh your “does it export values as mm or as inches” . Is that a question or a statement?
Why don’t units in the drawing translate to the exported file?
What good are units if they are not used by software that reads the file? I have never heard of anything like this where units in a drawing are totally ignored.

As was mentioned previously, STL files are unitless. The slicer software used by your 3D printer needs to be set to the units you want for printing.

It appears you have the impression that SketchUp is only for 3D printing which is not the case at all.

My guess is Box is setting up a file to see how it will print from your model.

Again, I don’t understand. I have a drawing that shows a length of 114.3 mm.
The units shown are 114.3. This is the length, in units shown, 114.3 mm.
If the slicer is set to mm. Why won’t this print something that is 114.3mm long?
If numbers for units have no meaning, why does the UI let you assign them??