STL Export to Slicer dimensions dont match

File dimensions I have created in Sketchup do not export accurately to my slicer. I’m working with a 20cm high object, fairly simple. When exported as STL and opened up in Flashprint the scale is way off, needs to be rescaled up by at least 500% to get back to 20cm high. I’ve tried all options in SU re. using meters, mm or cm, same result each time. Flashprint doesn’t seem to have any import scale options.
Whats confusing me is that a while back I was able to get a mm perfect match printing across multiple files exported as Sketchup STL and opened and printed via Flashprint. Cant figure why I cant do it now.

By their nature, STL files are dimensionless. From the Wikipedia: “STL files contain no scale information, and the units are arbitrary.” It seems to me that if your slicer software doesn’t have a setting for the import file units, you will have issues. How will it determine how big anything should be? I tried finding the user manual for Flashprint. No luck at least without installing it which I’d rather not do.

did you set your export units?


I saw this on another posting, I’ve looked all thru Sketchup for STL Export Units – preferences, info etc and cant find it anywhere. I’m using Sketchup Pro 2019.

Strange thing is that a few months back I was getting perfect millimetre accurate results, now its all over the place.

Where can I find Export Units?


Thanks, yes I know that and can rescale in Flashprint, its matching multiple prints exactly that’s the problem, what’s confusing is that it was working perfectly, now isn’t, I’m missing something… Flashprint is a very good slicer program,


On the bottom of the export dialog is the option button.

Thanks again.